LAPACK Archives

[Lapack] Lapack library link question

Hi,

I am compiling a code with ifort v9.0 which calls the LAPACK library  
however I have the following errors at the end of the compilation.

/usr/local/lib/liblapack.so: undefined reference to `e_wsfe'
/usr/local/lib/liblapack.so: undefined reference to `z_abs'
/usr/local/lib/liblapack.so: undefined reference to `c_sqrt'
/usr/local/lib/liblapack.so: undefined reference to `s_cmp'
/usr/local/lib/liblapack.so: undefined reference to `r_lg10'
/usr/local/lib/liblapack.so: undefined reference to `z_exp'
/usr/local/lib/liblapack.so: undefined reference to `c_exp'
/usr/local/lib/liblapack.so: undefined reference to `do_fio'
/usr/local/lib/liblapack.so: undefined reference to `z_sqrt'
/usr/local/lib/liblapack.so: undefined reference to `s_cat'
/usr/local/lib/liblapack.so: undefined reference to `s_stop'
/usr/local/lib/liblapack.so: undefined reference to `c_abs'
/usr/local/lib/liblapack.so: undefined reference to `d_lg10'
/usr/local/lib/liblapack.so: undefined reference to `s_wsfe'
/usr/local/lib/liblapack.so: undefined reference to `s_copy'
make: *** [test] Error 1

The same errors arise if I use the sys-admin LAPACK library or one I  
compiled independently. Can you please let me know whether you have  
come across this error before, for example could it be a compiler  
specific error? Googling appears to show that it has happened to a  
number of people - although no solution has been posted.

Thanks in advance,
Rachel Bean





<Prev in Thread] Current Thread [Next in Thread>
  • [Lapack] Lapack library link question, rachel bean <=


For additional information you may use the LAPACK/ScaLAPACK Forum.
Or one of the mailing lists, or