LAPACK Archives

[Lapack] trouble building clapack

Hi, i'm trying to use clapack to develop a code for modelling the  
shallow water equations.  i'm having trouble installing it.  I first  
tried installing it with the ATLAS BLAS libraries, but found out from  
the ATLAS people that what i was doing was wrong, that you need to  
link ATLAS at compile time.  so i went back and tried to build with  
the BLAS included with CLAPACK.  now i get this error when i do the  
make blaslib, make f2clib runs smoothly.  any help is greatly  
appreciated.

wl-dhcp141-188:~/CLAPACK ryanokuinghttons$ make blaslib
( cd BLAS/SRC; make )
gcc  -c isamax.c
gcc  -c sasum.c
gcc  -c saxpy.c
gcc  -c scopy.c
gcc  -c sdot.c
gcc  -c snrm2.c
gcc  -c srot.c
gcc  -c srotg.c
gcc  -c sscal.c
gcc  -c sswap.c
gcc  -c lsame.c
gcc  -c xerbla.c
gcc  -c sgemv.c
gcc  -c sgbmv.c
gcc  -c ssymv.c
gcc  -c ssbmv.c
gcc  -c sspmv.c
gcc  -c strmv.c
gcc  -c stbmv.c
gcc  -c stpmv.c
gcc  -c strsv.c
gcc  -c stbsv.c
gcc  -c stpsv.c
gcc  -c sger.c
gcc  -c ssyr.c
gcc  -c sspr.c
gcc  -c ssyr2.c
gcc  -c sspr2.c
gcc  -c sgemm.c
gcc  -c ssymm.c
gcc  -c ssyrk.c
gcc  -c ssyr2k.c
gcc  -c strmm.c
gcc  -c strsm.c
ar cr  isamax.o sasum.o saxpy.o scopy.o sdot.o snrm2.o srot.o srotg.o  
sscal.o sswap.o lsame.o xerbla.o \
sgemv.o sgbmv.o ssymv.o ssbmv.o sspmv.o strmv.o stbmv.o stpmv.o  
strsv.o stbsv.o stpsv.o sger.o ssyr.o sspr.o ssyr2.o sspr2.o sgemm.o  
ssymm.o ssyrk.o ssyr2k.o strmm.o strsm.o
ar: isamax.o: Inappropriate file type or format
make[1]: *** [single] Error 1
make: *** [blaslib] Error 2
wl-dhcp141-188:~/CLAPACK ryanokuinghttons$


-- 
Ryan O'Kuinghttons

<Prev in Thread] Current Thread [Next in Thread>
  • [Lapack] trouble building clapack, rokuingh at mines.edu <=


For additional information you may use the LAPACK/ScaLAPACK Forum.
Or one of the mailing lists, or