LAPACK Archives

[Lapack] Issues compiling clapack

Dear David,

Dear Sir,

Thanks for creating this package.

I downloaded the 3.2.1 package (from http://www.netlib.org/clapack/) and 
created the directories on my Linux computer, and then tried to follow the 
README.install instructions. 

That document suggests that there would be a make.inc file for each platform, 
i.e.: "CLAPACK/INSTALL/  -  Testing functions and pre-tested make.inc files 
for various platforms."  However, I did not find them there. All I found was 
the one "make.inc.example" file in the main directory.
indeed, we did a spring cleanup on those files...They were creating more 
confusion than really helping the users.
The make.inc.example is actually the one for linux and to copy it to make.inc 
is what you have to do.
I am going to update the README. Thank you for pointing that out.

However, I tried to proceed using this file.

Later in the install procedures, it says that if we are using an alternative 
version of blas (e.g. ATLAS), which I am, then we should make the wrapper 
library, libcblaswr.a, by running "make cblaswrap".  however this did not 
work, and when I looked in the makefile there was no cblaswrap target.  At 
this point I don't know how to proceed.  Note, I also looked into the 
make.inc.example (that I had renamed make.inc).
Yes again, this has changed (actually on this one, I am not sure why...)
So just a make would do.

Do the make.inc files for Linux exist online where I can access them, and do 
you have any suggestions regarding creating libcblaswr.a ?
Just discard, you seems all good to go.

Thanks in advance for your help.
Sincerely,
Julie
Cheers, David

David Todd
Center for Imaging Neurodegenerative Diseases
Veterans Health Services
San Francisco, CA
415-729-1063

_______________________________________________
Lapack mailing list
Lapack@Domain.Removed
http://lists.eecs.utk.edu/mailman/listinfo/lapack

**********************************************
Julie Langou; Research Associate in Computer Science
Innovative Computing Laboratory;
University of Tennessee from Denver, Colorado ;-)
julie@Domain.Removed; http://www.cs.utk.edu/~julie/







-------------- next part --------------
An HTML attachment was scrubbed...
URL: 
http://lists.eecs.utk.edu/mailman/private/lapack/attachments/20100420/f4518090/attachment.html
 

<Prev in Thread] Current Thread [Next in Thread>


For additional information you may use the LAPACK/ScaLAPACK Forum.
Or one of the mailing lists, or