LAPACK Archives

[Lapack] Lapack help

Dear RAVINDRA,
you are missing a BLAS library.
If you type make blaslib this will compile and create the Reference BLAS 
library. Then just type make, and the LAPACK testing will be executed.
It is recommended to use an optimized BLAS library like MKL, ATLAS, GOTO or 
ACML when linking but just for testing purpose the Reference BLAS is fine. (You 
need to change the BLASLIB variable in the make.inc to change the path to the 
BLAS library).
Sincerely,
Julie Langou
On Jun 9, 2010, at 6:44 AM, ravindra pankaj wrote:

sir i tried to install lapack-3.2.1 when I run make two errors occurred: 
terminal output is below.
( cd INSTALL; make; ./testlsame; ./testslamch; \
      ./testdlamch; ./testsecond; ./testdsecnd; ./testversion )
make[1]: Entering directory 
`/home/Ravindra/Download/softwares/prog_soft/lapack-3.2.1/INSTALL'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory 
`/home/Ravindra/Download/softwares/prog_soft/lapack-3.2.1/INSTALL'
  ASCII character set
  Tests completed
  Epsilon                      =   5.96046448E-08
  Safe minimum                 =   1.17549435E-38
  Base                         =    2.0000000    
  Precision                    =   1.19209290E-07
  Number of digits in mantissa =    24.000000    
  Rounding mode                =    1.0000000    
  Minimum exponent             =   -125.00000    
  Underflow threshold          =   1.17549435E-38
  Largest exponent             =    128.00000    
  Overflow threshold           =   3.40282347E+38
  Reciprocal of safe minimum   =   8.50705917E+37
  Epsilon                      =   1.11022302462515654E-016
  Safe minimum                 =   2.22507385850720138E-308
  Base                         =    2.0000000000000000     
  Precision                    =   2.22044604925031308E-016
  Number of digits in mantissa =    53.000000000000000     
  Rounding mode                =    1.0000000000000000     
  Minimum exponent             =   -1021.0000000000000     
  Underflow threshold          =   2.22507385850720138E-308
  Largest exponent             =    1024.0000000000000     
  Overflow threshold           =   1.79769313486231571E+308
  Reciprocal of safe minimum   =   4.49423283715578977E+307
 Time for 1,000,000 SAXPY ops  =  0.300E-02 seconds
 SAXPY performance rate        =   333.     mflops 
 Including SECOND, time        =  0.500E-02 seconds
 Average time for SECOND       =  0.400E-03 milliseconds
 Equivalent floating point ops =   133.     ops
 Time for 1,000,000 DAXPY ops  =  0.300E-02 seconds
 DAXPY performance rate        =   333.     mflops 
 Including DSECND, time        =  0.500E-02 seconds
 Average time for DSECND       =  0.400E-03 milliseconds
 Equivalent floating point ops =   133.     ops
 LAPACK            3 .           2 .           1
( cd SRC; make )
make[1]: Entering directory 
`/home/Ravindra/Download/softwares/prog_soft/lapack-3.2.1/SRC'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory 
`/home/Ravindra/Download/softwares/prog_soft/lapack-3.2.1/SRC'
( cd TESTING/MATGEN; make )
make[1]: Entering directory 
`/home/Ravindra/Download/softwares/prog_soft/lapack-3.2.1/TESTING/MATGEN'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory 
`/home/Ravindra/Download/softwares/prog_soft/lapack-3.2.1/TESTING/MATGEN'
( cd TESTING ; make )
make[1]: Entering directory 
`/home/Ravindra/Download/softwares/prog_soft/lapack-3.2.1/TESTING'
cd LIN ; make single
make[2]: Entering directory 
`/home/Ravindra/Download/softwares/prog_soft/lapack-3.2.1/TESTING/LIN'
gfortran -g   aladhd.o alaerh.o alaesm.o alahd.o alareq.o alasum.o alasvm.o 
chkxer.o icopy.o ilaenv.o xlaenv.o xerbla.o slaord.o schkaa.o schkeq.o 
schkgb.o schkge.o schkgt.o schklq.o schkpb.o schkpo.o schkps.o schkpp.o 
schkpt.o schkq3.o schkql.o schkqp.o schkqr.o schkrq.o schksp.o schksy.o 
schktb.o schktp.o schktr.o schktz.o sdrvgt.o sdrvls.o sdrvpb.o sdrvpp.o 
sdrvpt.o sdrvsp.o serrgt.o serrlq.o serrls.o serrps.o serrql.o serrqp.o 
serrqr.o serrrq.o serrtr.o serrtz.o sgbt01.o sgbt02.o sgbt05.o sgelqs.o 
sgeqls.o sgeqrs.o sgerqs.o sget01.o sget02.o sget03.o sget04.o sget06.o 
sget07.o sgtt01.o sgtt02.o sgtt05.o slaptm.o slarhs.o slatb4.o slatb5.o 
slattb.o slattp.o slattr.o slavsp.o slavsy.o slqt01.o slqt02.o slqt03.o 
spbt01.o spbt02.o spbt05.o spot01.o spot02.o spot03.o spot05.o spst01.o 
sppt01.o sppt02.o sppt03.o sppt05.o sptt01.o sptt02.o sptt05.o sqlt01.o 
sqlt02.o sqlt03.o sqpt01.o sqrt01.o sqrt02.o sqrt03.o sqrt11.o sqrt12.o 
sqrt13.o sqrt14.o sqrt15.o sqrt16.o sqrt17.o srqt01.o srqt02.o srqt03.o 
srzt01.o srzt02.o sspt01.o ssyt01.o stbt02.o stbt03.o stbt05.o stbt06.o 
stpt01.o stpt02.o stpt03.o stpt05.o stpt06.o strt01.o strt02.o strt03.o 
strt05.o strt06.o stzt01.o stzt02.o sgennd.o serrvx.o sdrvge.o sdrvsy.o 
serrge.o sdrvgb.o sdrvpo.o serrsy.o serrpo.o \
        ../../tmglib_LINUX.a ../../lapack_LINUX.a   ../../blas_LINUX.a -o 
xlintsts && mv xlintsts ../xlintsts
gfortran: ../../blas_LINUX.a: No such file or directory
make[2]: *** [../xlintsts] Error 1
make[2]: Leaving directory 
`/home/Ravindra/Download/softwares/prog_soft/lapack-3.2.1/TESTING/LIN'
make[1]: *** [xlintsts] Error 2
make[1]: Leaving directory 
`/home/Ravindra/Download/softwares/prog_soft/lapack-3.2.1/TESTING'
make: *** [lapack_testing] Error 2




please help  me in installing lapack. I'm sending u make.inc and Makefile 
that i used as attachment i'm using fedora 11.

thanks a lot

-- 
with best regards
RAVINDRA PANKAJ

<make.inc><Makefile>_______________________________________________
Lapack mailing list
Lapack@Domain.Removed
http://lists.eecs.utk.edu/mailman/listinfo/lapack

**********************************************
Julie Langou; Research Associate in Computer Science
Innovative Computing Laboratory;
University of Tennessee from Denver, Colorado ;-)
julie@Domain.Removed; http://www.cs.utk.edu/~julie/







-------------- next part --------------
An HTML attachment was scrubbed...
URL: 
http://lists.eecs.utk.edu/mailman/private/lapack/attachments/20100609/4a351d08/attachment-0001.html
 

<Prev in Thread] Current Thread [Next in Thread>


For additional information you may use the LAPACK/ScaLAPACK Forum.
Or one of the mailing lists, or