LAPACK Archives

[Lapack] Inquiries on LAPACK

Dear LAPACK Team,

My name is Kartika, a research scientist at APEC Climate Center.

I have some inquiries about LAPACK.

1. In the server I am using, the IT staff has installed LAPACK, but I faced
the problem when running my EOF program. This is my first time had this
problem, as I have never had this kind of problems in my previous
    The command I used to compile my program (eof.f) is:
    pgf90 -llapack -lblas -lacml -mcmodel=medium eof.f (the compilation went
    But, when I run it, I had this warning:
    ** ACML error: on entry to DSYEV  parameter number  5 had an illegal

   I tried to find out some solutions from internet, but I could not find

2. I added -lacml, as I had the following errors (when did not write -lacml)
   eof.o: In function `eigen_':
   eof.f90:(.text+0x169a): undefined reference to `dsyev_'

   The IT staf told me that the problem may come from my program, but I
don't think it comes from my program, as I used the program before, and it
worked well, but I used different server (previous institution).

3. Today, I tried to install LAPACK in my home directory. I downloaded
lapack3.3.1 from
    I changed little bit the and compiled it. But, I found the
error message as:
    /usr/bin/ld: BLAS/blas_LINUX.a: No such file: No such file or directory

   At this step, I donot know how to get blas_LINUX.a.

Could you help me to solve one the above problems (solution for no. 1, or
no.3) ?
Fyi, the server machine I am using is: Linux 2.6.18-194.el5 x86_64

Thank you and I look forward for your reply.
Best regards,
-------------- next part --------------
An HTML attachment was scrubbed...

<Prev in Thread] Current Thread [Next in Thread>

For additional information you may use the LAPACK/ScaLAPACK Forum.
Or one of the mailing lists, or