LAPACK Archives

[Lapack] Inquiries on LAPACK


1. In the server I am using, the IT staff has installed LAPACK, but I faced the 
problem when running my EOF program. This is my first time had this problem, as 
I have never had this kind of problems in my previous institution.
    The command I used to compile my program (eof.f) is:
    pgf90 -llapack -lblas -lacml -mcmodel=medium eof.f (the compilation went 
    But, when I run it, I had this warning:
    ** ACML error: on entry to DSYEV  parameter number  5 had an illegal value

   I tried to find out some solutions from internet, but I could not find it.

It means that the LDA parameter passed from eof.f to DSYEV is either less than 
the N parameter or less than 1.
(See: )

2. I added -lacml, as I had the following errors (when did not write -lacml) :
   eof.o: In function `eigen_':
   eof.f90:(.text+0x169a): undefined reference to `dsyev_'

The reference dsyev_ is in an LAPACK library, so you need to add one.

The linkage -llapack -lblas should have suffice though if -llapack and -lblas 
are what they are supposed to be ...

Adding -lacml helps if (  -llapack -lblas  ) is not correct.

 The IT staf told me that the problem may come from my program, but I don't 
think it comes from my program, as I used the program before, and it worked 
well, but I used different server (
previous institution).

Well this is ackward though because if acml is a well respected lapack library.

 3. Today, I tried to install LAPACK in my home directory. I downloaded 
lapack3.3.1 from
    I changed little bit the and compiled it. But, I found the error 
message as:
    /usr/bin/ld: BLAS/blas_LINUX.a: No such file: No such file or directory

Why not. all you need to do now is type "make blaslib" to make a reference blas 
Then for the linking something like:
pgf90 -mcmodel=medium eof.f PATH_TO_LAPACK/lapack_LINUX.a 
When the exe runs:
if you have a correct run, this might mean there is a mistake in ACML (weird) 
of something even weirder is happening somewhere
if you have an error, this probably means that eof.f does not set up the LDA 
parameter correctly.

-------------- next part --------------
An HTML attachment was scrubbed...

<Prev in Thread] Current Thread [Next in Thread>

For additional information you may use the LAPACK/ScaLAPACK Forum.
Or one of the mailing lists, or