LAPACK Archives

[Lapack] Problem with DGELSD

Bill,

I tried your original matrices (without the perturbation) in DGELSD in v3.4.0 
as well as v3.2.1 (this is the version supplied with MacOS 10.7 if you use 
-llapack)  and they both work.  

Is the problem you are seeing only present in v3.1.1? 

Rodney


On Mar 15, 2012, at 5:21 AM, Bill Birkett wrote:

Hello, LAPACK team,

I ran into a problem with DGELSD, which is described in the attached text 
file.

I've compared the source code of v3.1.1 to v3.4.0, and I don't see 
any differences that would change these results.

This may be a bug, or perhaps a lack of understanding on my part.

I'm trying to 'train' a neural network, which is the origin of these 
strange looking matrices.

DGELSS works correctly with the same inputs.

-Bill
-- 

William B. Birkett - <wbirkett@Domain.Removed>
Print Quality Consultant
Doppelganger, LLC  - http://www.doplganger.com/

48799 Meadow Drive, Plymouth, MI 48170 (USA)
Office: (734) 927-4232      FAX: (734) 468-0580
Cell: (734) 
516-4790<DGELSD_problem.txt>_______________________________________________
Lapack mailing list
Lapack@Domain.Removed
http://lists.eecs.utk.edu/mailman/listinfo/lapack



<Prev in Thread] Current Thread [Next in Thread>


For additional information you may use the LAPACK/ScaLAPACK Forum.
Or one of the mailing lists, or