LAPACK Archives

[Lapack] Error using DTRSYL / DLASY2 on MacOS 10.7.5

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Dear Lapack Team,

I recognize a strange error inside DLASY2 (LAPACK 3.4.2) on MacOS
10.7.5. Due to completely wrong results I used valgrind to get an idea
where they come friom because they are not reproducible on any other
operating system.
Valgrind said, that in dlasy2.f is an access to an uninitialized value
in lines 413,429,441,446 and 475. All these lines access the T16
variable and compare them to a reference value. This seems to cause a
wrong evaluation inside the "if" statement and the program flow goes
the wrong way.

I tried this using gcc 4.7.3 and gcc-4.8.1 from MacPorts and even the
Intel Fortran 13 compiler. I solved the problem inserting
 T16(1,1) = ZERO
 ...
 T16(4,4) = ZERO
directly after the declaration of the variables. This small
modification vanished all valgrind errors. The error also occurs when
using Apple's Accelerate Framework.

I tried the same code on Linux using gcc 4.6.x and 4.7.x and on MacOS
10.6.8 using gcc 4.8.1. and every thing works fine.

Do you have any idea about the reason of this strange problem?

regards
Martin K?hler

- -- 
Dipl.-Math. Martin K?hler
Max Planck Institute for
Dynamics of Complex Technical Systems
Sandtorstr. 1
39106 Magdeburg
Germany


phone: +49 (0)391 6110 445
email: koehlerm@Domain.Removed
www: http://www.mpi-magdeburg.mpg.de/mpcsc/koehlerm/
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iEYEARECAAYFAlH/oVwACgkQXeVvfIKK/EgUWACgnV9DOGQKlVcLwhlT992BN5Bu
7CkAoKF8kXjnqhiuTgj+v1skrSWxMvR4
=KSlc
-----END PGP SIGNATURE-----

<Prev in Thread] Current Thread [Next in Thread>


For additional information you may use the LAPACK/ScaLAPACK Forum.
Or one of the mailing lists, or