LAPACK Archives

[Lapack] BLAS installation

Dear Hamza,
The reference BLAS is included inside the LAPACK package. We do not use 
configure build system, just Makefiles
please download it from http://www.netlib.org/lapack/ 
<http://www.netlib.org/lapack/> - DIrect link is lapack-3.5.0.tgz 
<http://www.netlib.org/lapack/lapack-3.5.0.tgz>

From your Linux machine, to compile BLAS
tar xfvz lapack-3.5.0.tgz
cd lapack-3.5.0
make blaslib

if you need the LAPACK library, just type
make

Hope it helps

On Apr 22, 2015, at 12:46 PM, MUHAMMAD HAMZA HUMAYUN 
<mhumayun13@Domain.Removed> wrote:

Hi

Hope you are doing fine. 

? just today started learning MEEP and am returning to linux environment 
after a long time. ? want to install BLAS however i am not able to use 
./configure on it. Through browsing i learnt it consists of some .f files.
from the link : 
http://ab-initio.mit.edu/wiki/index.php/Template:Installing_BLAS_and_LAPACK 
<http://ab-initio.mit.edu/wiki/index.php/Template:Installing_BLAS_and_LAPACK>

? tried their steps :
f77 -c -O3 *.f   # compile all of the .f files to produce .o files
ar rv libblas.a *.o    #  combine the .o files into a library
su -c "cp libblas.a /usr/local/lib"   # switch to root and install
when i ran the 1st command i got following message: 

Error on line 35: Declaration error for len_trim: unknown intrinsic function
/usr/bin/f77: aborting compilation

and not all .f are converted to .o

and after running 3rd command i am still not able to install it

Can you help me with this

Best Regards

Hamza
_______________________________________________
Lapack mailing list
Lapack@Domain.Removed
http://lists.eecs.utk.edu/mailman/listinfo/lapack

-------------- next part --------------
An HTML attachment was scrubbed...
URL: 
<http://lists.eecs.utk.edu/mailman/private/lapack/attachments/20150423/fd8e5f0d/attachment.html>

<Prev in Thread] Current Thread [Next in Thread>


For additional information you may use the LAPACK/ScaLAPACK Forum.
Or one of the mailing lists, or