ScaLAPACK Archives

[Scalapack] installer freezes when checking mpicc (MPICH ch-p4mpd)

Greetings,

I tried to use scalapack installer 0.91 on a x86_64 PC with a linux
(openSUSE 11.0) using standard "factory" MPIs, LAPACK AND BLAS (i.e.
MPI, LAPACK and BLAS distributed as packages with the openSUSE).

I have succesfully built scalapack with openMPI. (Although I have not
tested it yet.) Then I tried to build scalapack with MPICH (using the
ch-p4mpd device). In this case the installer freezes when checking mpicc
(and also on a 32-bit PC). After a long waiting I interrupted the
process (the ^C in the line "Checking if mpicc works...^C"). See below:


# ./setup.py  --mpibindir=/opt/mpich/ch-p4mpd/bin
--mpicc=/opt/mpich/ch-p4mpd/bin/mpicc
--mpif77=/opt/mpich/ch-p4mpd/bin/mpif77  --mpiincdir=/opt/mpich/include
--blaslib=/usr/lib64/libblas.a  --lapacklib=/usr/lib64/liblapack.a
========================================
Setting up the framework

MPI bin dir is  /opt/mpich/ch-p4mpd/bin
mpicc is  /opt/mpich/ch-p4mpd/bin/mpicc
mpif77 is  /opt/mpich/ch-p4mpd/bin/mpif77
MPI include dir is  /opt/mpich/include
Checking if mpicc works...^C
Traceback (most recent call last):
  File "./setup.py", line 25, in <module>
    frame = Frame(sys.argv[1:])
  File
"/usr/local/src/SCALAPACK/scalapack_installer_0.91_MPICH_ch-p4mpd_factoryBlasLapack/script/framework.py",
 line 107, in __init__
    self.check_mpicc()
  File
"/usr/local/src/SCALAPACK/scalapack_installer_0.91_MPICH_ch-p4mpd_factoryBlasLapack/script/framework.py",
 line 375, in check_mpicc
    (output, error, retz) = runShellCommand(comm)
  File
"/usr/local/src/SCALAPACK/scalapack_installer_0.91_MPICH_ch-p4mpd_factoryBlasLapack/script/utils.py",
 line 68, in runShellCommand
    ready = select.select(lst, [], [])
KeyboardInterrupt



I just add that I have succesfully compiled, linked and run another
application using this mpicc from the MPICH (also from the openMPI) on
the same machine. The MPICH is the version 1.2.7.

Cheers and thanks for your work.
Martin Konopka.


------------------------------------------------------------------------
Dr. Martin Konopka                 http://www.kf.elf.stuba.sk/~konopka
Department of Physics, CCMS                      tel: +421-2-60291 714
Slovak University of Technology (FEI STU)        fax: +421-2-65411 483
Ilkovicova 3, 812 19 Bratislava, Slovakia
------------------------------------------------------------------------



<Prev in Thread] Current Thread [Next in Thread>
  • [Scalapack] installer freezes when checking mpicc (MPICH ch-p4mpd), Martin Konopka <=


For additional information you may use the LAPACK/ScaLAPACK Forum.
Or one of the mailing lists, or