ScaLAPACK Archives

[Scalapack] Scalapack on Linux-MPI-Cluster Error compiling tests

Hi Moritz,
Did you try to use the scalapack installer?
It is available at http://www.netlib.org/scalapack/
Let me know if this solves your problem.
Regards,
Julie
On Jan 14, 2011, at 9:32 AM, Schlarb, Moritz wrote:

Hello!
 
I?m trying to get Scalapack working  in our cluster environment.
We?re using mvapich and openmpi. BLAS and LAPACK and ATLAS are all available 
on the machine.
With gcc and sun (both 64 bit) and the mvapich libhraries I could compile 
BLACS and I could compile scalapack, but when I do
$ make exe
in the scalapack folder, I get these errors at both compilers:
 
mpif77  -o /homes/2/schlarbm/scalapack_sun-64_mvapich/TESTING/xspblas1tst 
psblas1tst.o psblastst.o slamch.o pblastst.o PB_Cwarn.o PB_Cabort.o 
/homes/2/schlarbm/scalapack_sun-64_mvapich/libscalapack.a 
/homes/2/schlarbm/blacs_sun-64_mvapich/LIB/blacsF77init_MPI-LINUX-0.a 
/homes/2/schlarbm/blacs_sun-64_mvapich/LIB/blacs_MPI-LINUX-0.a 
/homes/2/schlarbm/blacs_sun-64_mvapich/LIB/blacsF77init_MPI-LINUX-0.a 
/usr/local/cluster/atlas/current_sun/lib/liblapack.a 
/usr/local/cluster/atlas/current_sun/lib/libcblas.a 
/usr/local/cluster/atlas/current_sun/lib/libf77blas.a 
/usr/local/cluster/atlas/current_sun/lib/libptcblas.a 
/usr/local/cluster/atlas/current_sun/lib/libptf77blas.a 
/usr/local/cluster/atlas/current_sun/lib/libatlas.a
[?]
psblastst.o: In function `pslamch_':
psblastst.f:(.text+0x160fd): undefined reference to `pb_topget_'
psblastst.f:(.text+0x16199): undefined reference to `pb_topget_'
psblastst.o: In function `pb_schekpad_':
psblastst.f:(.text+0x1c7d4): undefined reference to `pb_topget_'
PB_Cwarn.o: In function `PB_Cwarn':
PB_Cwarn.c:(.text+0xb9): undefined reference to `pb_noabort__'
PB_Cabort.o: In function `PB_Cabort':
PB_Cabort.c:(.text+0x2f): undefined reference to `pb_noabort__'
make[1]: *** [/homes/2/schlarbm/scalapack_sun-64_mvapich/TESTING/xspblas1tst] 
Fehler 1
make[1]: Leaving directory 
`/homes/2/schlarbm/scalapack_sun-64_mvapich/PBLAS/TESTING'
make: *** [pblasexe] Fehler 2
 
Please see attached SLMake.inc, too.
 
Can someone identify the cause of this undefinied reference error and help me 
with this?
 
Best regards
Moritz Schlarb
<SLmake.inc>_______________________________________________
Scalapack mailing list
Scalapack@Domain.Removed
http://lists.eecs.utk.edu/mailman/listinfo/scalapack

**********************************************
Julie Langou; Research Associate in Computer Science
Innovative Computing Laboratory;
University of Tennessee from Denver, Colorado ;-)
julie@Domain.Removed; http://www.cs.utk.edu/~julie/







-------------- next part --------------
An HTML attachment was scrubbed...
URL: 
http://lists.eecs.utk.edu/mailman/private/scalapack/attachments/20110114/5c775793/attachment-0001.html
 

<Prev in Thread] Current Thread [Next in Thread>


For additional information you may use the LAPACK/ScaLAPACK Forum.
Or one of the mailing lists, or