ScaLAPACK Archives

[Scalapack] issue with running Scalapack, and with posting issue on foru

Thank you Julie!
I did try reference BLAS and LAPACK and also ran into segmentation faults with 
that (although since the application that I'm linking with SCALAPACK is also 
using BLAS and LAPACK natively there might have been some incompatibility - I 
tried pointing the application to the reference BLAS and LAPACK implementations 
but that didn't work either). I am running on a Sandy bridge machine. I did try 
to run the testing but it didn't work either (it seemed though that some of the 
paths were off).
At the moment I'm thinking of just intercepting the call to the SCALAPACK 
function I wanted to use and rewriting it. If that does not work then I will 
investigate more the issue with building Scalapack.
Thank you!
Sarah

From: julie langou [mailto:julie@Domain.Removed]
Sent: Tuesday, October 08, 2013 7:58 AM
To: Sarah Tariq
Cc: scalapack@Domain.Removed; Don Fike
Subject: Re: [Scalapack] issue with running Scalapack, and with posting issue 
on forum

Dear Sarah,
Regarding the post on the forum, I guess it is the code part that is causing 
problem (maybe you need to enclose it in a code section)

First, we never tried to build ScaLAPACK with Intel MPI. We should very 
certainly check this.
 A few questions:
             - What kind of machine are you running on?
             - Did you try to run the testings? (maybe you have a problem in 
your application)

To build it and test it, it is better to use the Reference BLAS and LAPACK. 
Once everything is fine with the Reference BLAS and LAPACK, you can change to 
Intel MKL.
Regards,
Julie

On Oct 7, 2013, at 2:49 PM, Sarah Tariq 
<stariq@Domain.Removed<mailto:stariq@Domain.Removed>> wrote:


Hi,
I have an issue with running an application with a version of scalapack that I 
am building (detailed below). I am trying to post this issue on the forum (as a 
new topic under User Discussion) but I get the message: "This message was 
flagged as spam and has been denied." My user name is georgia8.
I'm not sure if I'm doing something wrong in the way I am posting this? If you 
have any suggestions about what I should change in order to post this issue 
successfully, or about my issue in general I would really appreciate it,
Thank you!
Sarah


issues building and running Scalapack with intel MKL 2013

I am trying to build Scalapack (using the installer) with intel mkl (2013) and 
although Scalapack builds fine, when I try to use it in an application I get a 
segmentation fault inside Scalapack. If I just use the scalapack library 
provided by intel (libmkl_scalapack_lp64) the application runs fine, but I 
would like to be able to build scalapack from source since I'm trying to modify 
some functions. Here is what I have tried:

[b]build scalapack using the installer:[/b]
MPIBINDIR=/shared/apps/rhel-6.2/intel/ics-2013/impi/4.1.0.024/bin64
LAPACKLIB=$MKLROOT/lib/intel64/libmkl_blas95_lp64.a
BLASLIB=$MKLROOT/lib/intel64/libmkl_lapack95_lp64.a
./setup.py --prefix=$PWD --mpibindir=$MPIBINDIR --blaslib=$BLASLIB 
--lapacklib=$LAPACKLIB --fcflags=-g --ccflags=-g --notesting


[b]build the application using the following;[/b]
-L$(TACC_FFTW2_LIB) -lfftw \
          -L$(TACC_MKL_LIB)/lib/intel64 -lmkl_intel_lp64 \
           -L$(SCALAPACK)/lib -lscalapack \
          -lmkl_sequential -lmkl_core -lpthread \
          -lmkl_lapack95_lp64 -lmkl_blacs_intelmpi_lp64 -lmkl_blas95_lp64 -lm \
          -L$(UUID_LIB_DIR) -luuid \
          -Bstatic \
          -L$(XERCESCDIR)/lib -lxerces-c \


[b]run application and get a segmentation fault. Here is the backtrace:[/b]
#0  0x00002aaaab1ec6b3 in zdotc_ () from 
/shared/apps/rhel-6.2/intel/ics-2013/mkl/lib/intel64/libmkl_intel_lp64.so
#1  0x0000000000674ca4 in pzpotf2 (uplo='l', n=560, a=..., ia=1, ja=1, 
desca=..., info=0, _uplo=1) at pzpotf2.f:303
#2  0x00000000005f09b8 in pzpotrf (uplo='l', n=560, a=..., ia=1, ja=1, 
desca=..., info=0, _uplo=0) at pzpotrf.f:304

Is this supposed to work? I've also tried downloading the reference blas and 
lapack implemetations and that didnt work either. I really appreciate any 
thoughts or suggestions,
thanks!


________________________________
This email message is for the sole use of the intended recipient(s) and may 
contain confidential information.  Any unauthorized review, use, disclosure or 
distribution is prohibited.  If you are not the intended recipient, please 
contact the sender by reply email and destroy all copies of the original 
message.
________________________________
_______________________________________________
Scalapack mailing list
Scalapack@Domain.Removed<mailto:Scalapack@Domain.Removed>
http://lists.eecs.utk.edu/mailman/listinfo/scalapack

-------------- next part --------------
An HTML attachment was scrubbed...
URL: 
<http://lists.eecs.utk.edu/mailman/private/scalapack/attachments/20131008/f125d88e/attachment.html>

<Prev in Thread] Current Thread [Next in Thread>


For additional information you may use the LAPACK/ScaLAPACK Forum.
Or one of the mailing lists, or