ScaLAPACK Archives

[Scalapack] scalapack installer 1.0.2

Hello,

I'm running into a few problems with the scalapack installer. I'm trying to
install using intel compilers, downloading and installing blas & lapack as
well.

My first issue is that whilst I run with intel compiler gfortran is
hardcoded into netlib.py. The end result is that ifort flags (in this case
-mp) gets passed to gfortran and the build of lapack fails.
Fixing this by replacing gfortran with ifort allows me to get quite a lot
further but I run into problems when compiling the tests.

The issue is with the flag -nofor_main (which is listed as -nofor-main in
ifort?) which comes from framework.py. The issue here is that this
eventually gets passed to the c compiler in the scalalack testing, which
causes a further build fail. Particularly the c-compiler is invoked with
the flags CCLOADFLAGS which is set to self.config.ldflags_fc at line 63 of
scalapack.py.

Switching
FCLOADFLAGS  ="""+self.config.ldflags_c+"""
CCLOADFLAGS   = """+self.config.ldflags_fc+"""

to

FCLOADFLAGS  ="""+self.config.ldflags_fc+"""
CCLOADFLAGS   = """+self.config.ldflags_c+"""

Fixes this problem. (Makes sense)

However then the BLACS testing fails unless I explicitly specify
--mpirun=mpirun which I didn't think should be necessary from what is
listed when running ./setup.py -h.

After this the installation appears to run ok but the testing on PBLAS
seems to take a long time. It's been running "xcpblas1tst" for about 4000
minutes now, so I'm wondering if something isn't quite right there.

Given this got a little hacky I thought I'd send an email in case I'm doing
something wrong, or I need to do something else?

Thanks,

Tom
-------------- next part --------------
An HTML attachment was scrubbed...
URL: 
<http://lists.eecs.utk.edu/mailman/private/scalapack/attachments/20140721/93596fb0/attachment.html>

<Prev in Thread] Current Thread [Next in Thread>
  • [Scalapack] scalapack installer 1.0.2, Tom Goffrey <=


For additional information you may use the LAPACK/ScaLAPACK Forum.
Or one of the mailing lists, or