Page 1 of 1

ScaLAPACK 2.0.0 installation problem

PostPosted: Thu Jan 12, 2012 4:29 am
by zarkobodroski
I have a problem with Python installer for ScaLAPACK 2.0.0 (scalapack_installer.tgz).
Installation process start scalapack.py and then stuck on “Running (some) ScaLAPACK test routines...”.

I used this to start installation:
./setup.py --mpiincdir /usr/lib/openmpi/include --downall

Please help me with this problem.

Re: ScaLAPACK 2.0.0 installation problem

PostPosted: Thu Jan 12, 2012 9:43 am
by admin
HI,
Could you please copy paste sca_testing and scalog from the build/log folder
Julie

Re: ScaLAPACK 2.0.0 installation problem

PostPosted: Thu Jan 12, 2012 9:56 am
by zarkobodroski
admin wrote:HI,
Could you please copy paste sca_testing and scalog from the build/log folder
Julie


Hi Julie,
It's too big for copy/paste. I hope that's ok to give public URL here: log.zip

Zarko.

Re: ScaLAPACK 2.0.0 installation problem

PostPosted: Thu Jan 12, 2012 10:10 am
by admin
ok, two things.
- First there is a problem in the installer (look at the last line of the sca_log)
To avoid it, just go in
/homes/2/schlarbm/src/scalapack_installer/build/scalapack
make sure in the SLmake.inc the scalapack library is just libscalapack.a
and type make

- Second, it seems that your installation works fine, just maybe rerun by hand xcheevr to be sure
go in TESTING and type
/opt/mvapich2/gen2_1.6_gcc-64/bin/mpirun -np 4 ./xcheevr

It is surprising that the test stop while writing a string....
'TEST 8 - test a medium matrix - L and U'
24 1 1 1 22 N 0.00 -1.00 0.0 0.0 PASSED EVR
24 1 1 1 22 N 0.00 -1.00 0.0 0.0 PASSED EVR
24 3 1 2 22 N 0.00 -1.00 0.0 0.0 PASSED EVR
24 3 1 2 22 N 0.00 -1.00 0.0 0.0 PA

Re: ScaLAPACK 2.0.0 installation problem

PostPosted: Thu Jan 12, 2012 11:09 am
by zarkobodroski
admin wrote: - First there is a problem in the installer (look at the last line of the sca_log)
To avoid it, just go in
/homes/2/schlarbm/src/scalapack_installer/build/scalapack
make sure in the SLmake.inc the scalapack library is just libscalapack.a
and type make

Done.

admin wrote: - Second, it seems that your installation works fine, just maybe rerun by hand xcheevr to be sure
go in TESTING and type
/opt/mvapich2/gen2_1.6_gcc-64/bin/mpirun -np 4 ./xcheevr

Tests completed without errors.

It should work now. Thank you for help!
Zarko.