Page 1 of 1

Compiling and Building BLACS INSTALL Testing to set correct

PostPosted: Wed Jun 28, 2017 8:18 am
by admin
Note: this is a post from the user GIBBOGLE. `admin` is posting the post because the post is flagged as `SPAM` by the forum software. Here is the post of GIBBOGLE.



CMake Error at CMAKE/FortranMangling.cmake:27 (MESSAGE):
Configure in the BLACS INSTALL directory FAILED
Call Stack (most recent call first):
CMakeLists.txt:122 (COMPILE)
Configuring incomplete, errors occurred!

See also "D:/ScalaPack/Build/CMakeFiles/CMakeOutput.log".

I get this error with the two generators I've tried: Visual Studio 8 2005, and CodeBlocks - MinGW Makefiles.

The last message in CMakeOutput.log refers to a successful test of something else. I am using cmake 3.0.2.

Any suggestions?

Re: Compiling and Building BLACS INSTALL Testing to set corr

PostPosted: Thu Jun 29, 2017 1:13 am
by admin
Did you look at http://icl.cs.utk.edu/lapack-for-window ... index.html?
It has been a while since we worked on ScaLAPACK under Windows.
I am not sure we got a ScaLAPACK MinGW built running under VS .... nonetheless the Windows Intel compiler should work fine.
Julie