LAPACK 3.2.1 and CMake 2.8.12

Post here if you have a question about linking your program with LAPACK or ScaLAPACK library

LAPACK 3.2.1 and CMake 2.8.12

Postby moritunkas » Mon Nov 04, 2013 5:14 am

Hello everybody,

I am trying to install jrl-mathtools in my machine but I have some problem with LAPACK, BLAS and Cmake.

The operative system is Ubuntu 10.04.4 LTS 32-bit.

The version of LAPACK is 3.2.1

The version of BLAS is 1.2

Cmake is updated with the last version 2.8.12

Basically, during the installation the terminal shows the following message:

Code: Select all
CMake Error at /usr/share/cmake-2.8/Modules/FindBLAS.cmake:457 (message):
  A required library with BLAS API not found.  Please specify library
  location.
Call Stack (most recent call first):
  /usr/share/cmake-2.8/Modules/FindLAPACK.cmake:139 (find_package)
  cmake/lapack.cmake:29 (FIND_PACKAGE)
  CMakeLists.txt:45 (SEARCH_FOR_LAPACK)
All the packages theoretically are installed. Then, I really don't have idea about how to solve the problem.


Someone can help me? What could be the error?

Thank you very much
moritunkas
 
Posts: 2
Joined: Mon Nov 04, 2013 5:07 am

Re: LAPACK 3.2.1 and CMake 2.8.12

Postby admin » Sat Jan 11, 2014 2:33 pm

It seems that you checked USE_OPTIMIZED_BLAS option but you do not have any BLAS available on your machine.
Either use the Reference BLAS provided by unchecking USE_OPTIMIZED_BLAS or specify the BLAS library in the BLAS_LIBRARIES variable
Hope it helps
admin
Site Admin
 
Posts: 608
Joined: Wed Dec 08, 2004 7:07 pm


Return to Linking Problem

Who is online

Users browsing this forum: No registered users and 2 guests

cron