BLAS Test failed on izamax

Open discussion regarding features, bugs, issues, vendors, etc.

BLAS Test failed on izamax

Postby Yoko » Fri Sep 30, 2005 12:49 pm

I installed LAPACK (and contained BLAS) and run the tests for BLAS and for LAPACK. Executing xblat1z, I got the message, that Test Nr 10 (IZAMAX) failed. Does anybody know, if this is a bug or if I can fix this problem?

Running the LAPACK-Tests, I got the message, that a part of the tests failed to pass the threshold. What can I do and what does this result exactly mean?
Yoko
 
Posts: 2
Joined: Thu Sep 29, 2005 9:47 am

Postby Yoko » Sun Oct 02, 2005 1:49 am

I tried know the altas version. The tests are ok there.
Yoko
 
Posts: 2
Joined: Thu Sep 29, 2005 9:47 am

Postby Julien Langou » Sun Oct 02, 2005 5:32 am

Hello,

yes you are correct.

Basically IZAMAX can fail its testing routine depending on the BLAS tested.
We already have spotted this but never take any action on it. The problem is more on the tester (or the definition of IZAMAX) than in the reference BLAS routine itself (or the compiler) .

The problems comes from the testing routines. It asked to IZAMAX which elements is the biggest in term of absolute value [abs(z) = |Re(z)| + |Im(z)|] amongst the two following double-complex-entry vectors
(0.3,0.1) (0.1,0.4) (0.4,0.1) (0.1,0.2) [first failure]
(0.3,0.1) (0.1,0.4) (0.4,0.1) (0.1,0.2) [second failure]
The expected answer by the tester is the second entry in both cases.
The computed answer (on GNU-Fortran-g77-compiler BLAS) is the third one.
So the tester indicates a failure.

This failure can be removed at the tester level by removing the test...
Or at the reference BLAS level by defining the function dcabs1 (basically do in IZAMAX as is done in ICAMAX )

I guess nothing dramatic for user application but we should fix this.
I'll contact the other developers and we take action on this and report.

Julien
Julien Langou
 
Posts: 733
Joined: Thu Dec 09, 2004 12:32 pm
Location: Denver, CO, USA


Return to User Discussion

Who is online

Users browsing this forum: Bing [Bot], Yahoo [Bot] and 2 guests