LAPACK freezing during the test

Open discussion regarding features, bugs, issues, vendors, etc.

Postby anmunoz » Tue Feb 20, 2007 1:42 pm

Hi Dominique:

Thank you very much for the information, I will try varying the optimization flags and also the compiler and I will post here what happens.

be happy,

Andrés
anmunoz
 
Posts: 15
Joined: Fri May 12, 2006 4:18 pm

Postby Julien Langou » Tue Feb 20, 2007 7:54 pm

Andres,
you might as well switch to lapack-3.1, as mentionned by Dominique, his patch
is ok but refers to 3.0, slarre as been changed a lot from 3.0 to 3.1 thanks to
work from Beresford Parlett, Jim Demmel, Inderjit Dhillon, Osni Marques, and Christof
Voemel and there is no need for this patch any more.
(Thanks Dominique anyhow for the pacth on 3.0.)
Julien.
Julien Langou
 
Posts: 835
Joined: Thu Dec 09, 2004 12:32 pm
Location: Denver, CO, USA

Postby anmunoz » Wed Feb 21, 2007 5:16 pm

Hi Julien:

I'm using LAPACK 3.1.0, and my problem is with xlintsts which is the first test LAPACK does, last time my problem was with the eigenvalue test, I haven't checked the other tests in this architecture yet.

As Dominique suggested I changed the compilation options to no optimization i.e. f77 -f -u and it stalls in a different place:

TRANS='N', M= 5, N= 10, NRHS= 15, NB= 1, type 2, test( 2)= 0.16801E+07
TRANS='T', M= 5, N= 10, NRHS= 15, NB= 1, type 2, test( 2)= 0.10074E+07
TRANS='N', M= 5, N= 10, NRHS= 15, NB= 3, type 2, test( 2)= 0.18362E+07
TRANS='T', M= 5, N= 10, NRHS= 15, NB= 3, type 2, test( 2)= 0.11995E+07
TRANS='N', M= 5, N= 10, NRHS= 15, NB= 3, type 2, test( 2)= 0.16361E+07
TRANS='T', M= 5, N= 10, NRHS= 15, NB= 3, type 2, test( 2)= 0.97411E+06
TRANS='N', M= 5, N= 10, NRHS= 15, NB= 3, type 2, test( 2)= 0.18796E+07
TRANS='T', M= 5, N= 10, NRHS= 15, NB= 3, type 2, test( 2)= 0.11708E+07
TRANS='N', M= 5, N= 10, NRHS= 15, NB= 20, type 2, test( 2)= 0.18971E+07
TRANS='T', M= 5, N= 10, NRHS= 15, NB= 20, type 2, test( 2)= 0.82252E+06

I'm going to try with g77.

If you have any ideas I will certainly give them a try.

thank you very much,

Andrés
anmunoz
 
Posts: 15
Joined: Fri May 12, 2006 4:18 pm

Postby Julien Langou » Wed Feb 21, 2007 5:36 pm

hello Andres, can you start a new post topics and reminding lapack-version/machine/compiler/blas/flags and restate the problem, please? I have half of the answer to teh questions above by digging in the previous post but I am lost in this topic, too many post, non related. That would be good to start fresh, Cheers, Julien.
Julien Langou
 
Posts: 835
Joined: Thu Dec 09, 2004 12:32 pm
Location: Denver, CO, USA

Previous

Return to User Discussion

Who is online

Users browsing this forum: No registered users and 6 guests

cron