BLAS and ATLAS both in my system

Open discussion regarding features, bugs, issues, vendors, etc.

BLAS and ATLAS both in my system

Postby isulsz » Sat Sep 04, 2010 1:36 am

Hi, I am new to LAPACK. I am using Fedora 12 and obtained LAPACK from the package installer (yum). I know that I already have ATLAS in my system. But when I try to install LAPACK, the installer indicates the dependency on BLAS and I installed BLAS also. I don't think a BLAS is necessary because I have already had a ATLAS, am I right? In this case, which one will be used by LAPACK? Is there anyway to let LAPACK to use ATLAS only?


By the way, another question in my mind is, is LAPACK multithread safe? I know that currently LAPACK it self is not multithreaded. But what if we use it in a multithreaded program, e.g., multiple threads call the same function in LAPACK at the same time? Is it safe?

Thanks.
isulsz
 
Posts: 1
Joined: Sat Sep 04, 2010 1:25 am

Return to User Discussion

Who is online

Users browsing this forum: Yahoo [Bot] and 4 guests

cron