Cannot find libI77.a or libF77.a after CLAPACK install.

Open discussion regarding features, bugs, issues, vendors, etc.

Cannot find libI77.a or libF77.a after CLAPACK install.

Postby qiaoshiya » Thu Mar 31, 2011 9:05 pm

I just installed CLAPACK on Ubuntu 10.10. Everything seems to go fine during the install process ("make" seemed to take care of everything). After install I checked all the .out files in the /TESTING directory, and according to those files, all the tests ran smoothly.

However, when I went to copy all of the .a files into /usr/local/lib, I noticed some were (seemingly) missing. I can't find libI77.a or libF77.a. Where should these files be located? I tried to run a test by solving a linear system, and my code fails to link b/c (I assume) these files are missing. I get the 'undefined reference to SGESV' error.

Could someone tell me where to locate these files? Thanks.
qiaoshiya
 
Posts: 3
Joined: Thu Mar 31, 2011 2:59 pm

Re: Cannot find libI77.a or libF77.a after CLAPACK install.

Postby admin » Fri Apr 01, 2011 3:20 am

Hi those libraries are not longer present in CLAPACK.
Could you provide your link and an extract of your program?
Julie
admin
Site Admin
 
Posts: 468
Joined: Wed Dec 08, 2004 7:07 pm

Re: Cannot find libI77.a or libF77.a after CLAPACK install.

Postby qiaoshiya » Fri Apr 01, 2011 8:53 am

Thanks for the prompt response! I was able to solve my problem by reading this thread from last year: viewtopic.php?f=2&t=2020

Thanks again.
qiaoshiya
 
Posts: 3
Joined: Thu Mar 31, 2011 2:59 pm


Return to User Discussion

Who is online

Users browsing this forum: Bing [Bot] and 1 guest