MUMPS run-time error - IMPI

Open discussion regarding features, bugs, issues, vendors, etc.

MUMPS run-time error - IMPI

Postby Qsolver » Mon Jun 27, 2011 2:10 pm

Hello,

I am testing parallel linear solver package MUMPS (which uses ScaLAPACK) with a testing program (dsimpletest) provided by the package. It is built in 64-bit Linux Redhat 3 system and uses HP-MPI. However, it got the following run-time error:

==========
machine 594% mpirun -np 4 dsimpletest
dsimpletest: MPI_Init: MPI BUG: IMPI is not supported on Linux|64bit host
dsimpletest: MPI_Init: MPI BUG: IMPI is not supported on Linux|64bit host
MPI Application rank 1 exited before MPI_Init() with status 1
mpirun: Broken pipe
=========

Do you have any idea what IMPI is? I found online a HP-MPI version 1.7 release note, it says “The interoperable MPI protocal (IMPI) extends the power of MPI by allowing applications to run heterogensous clusters of machines with various architectures and operating systems. ...Currently IMPI is not supported in multi-threaded library.” What can I do about it? FYI, I have tested ScaLAPACK lib using its testing programs (which uses the same HP-MPI libs) without any problem.

Thanks a lot for your help.

Regards,
Qin
Qsolver
 
Posts: 6
Joined: Fri Apr 01, 2011 10:50 am

Re: MUMPS run-time error - IMPI

Postby admin » Fri Jul 01, 2011 4:28 am

You can have a look here: http://www.lam-mpi.org/faq/category10.php3

I would suggest first to test your MPI implementation, than your ScaLAPACK implementation then MUMPS.

We recommend to use open MPI, http://www.open-mpi.org/.
It should be easy to install it on your machine.
admin
Site Admin
 
Posts: 486
Joined: Wed Dec 08, 2004 7:07 pm


Return to User Discussion

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest