Problem building LAPACK 3.3.1 on Mac LION

Open discussion regarding features, bugs, issues, vendors, etc.

Problem building LAPACK 3.3.1 on Mac LION

Postby shubham111gupta » Thu Sep 01, 2011 12:43 am

I am trying to make LAPACK 3.3.1 on mac with blas libraries provide with package

using
gfortran 4.6.1

<make.inc>
OPT = O2
NOOPT = O0
BLASLIB = ../../blas$(PLAT).a
{rest unaltered}
<MakeFile>
#lib: lapacklib tmglib
lib: blaslib variants lapacklib tmglib

{rest unaltered}



getting error during testing

gfortran -fimplicit-none -g -O2 -c slaord.f -o slaord.o
gfortran -g aladhd.o alaerh.o alaesm.o alahd.o alareq.o alasum.o alasvm.o chkxer.o icopy.o ilaenv.o xlaenv.o xerbla.o slaord.o schkaa.o schkeq.o schkgb.o schkge.o schkgt.o schklq.o schkpb.o schkpo.o schkps.o schkpp.o schkpt.o schkq3.o schkql.o schkqp.o schkqr.o schkrq.o schksp.o schksy.o schktb.o schktp.o schktr.o schktz.o sdrvgt.o sdrvls.o sdrvpb.o sdrvpp.o sdrvpt.o sdrvsp.o serrgt.o serrlq.o serrls.o serrps.o serrql.o serrqp.o serrqr.o serrrq.o serrtr.o serrtz.o sgbt01.o sgbt02.o sgbt05.o sgelqs.o sgeqls.o sgeqrs.o sgerqs.o sget01.o sget02.o sget03.o sget04.o sget06.o sget07.o sgtt01.o sgtt02.o sgtt05.o slaptm.o slarhs.o slatb4.o slatb5.o slattb.o slattp.o slattr.o slavsp.o slavsy.o slqt01.o slqt02.o slqt03.o spbt01.o spbt02.o spbt05.o spot01.o spot02.o spot03.o spot05.o spst01.o sppt01.o sppt02.o sppt03.o sppt05.o sptt01.o sptt02.o sptt05.o sqlt01.o sqlt02.o sqlt03.o sqpt01.o sqrt01.o sqrt01p.o sqrt02.o sqrt03.o sqrt11.o sqrt12.o sqrt13.o sqrt14.o sqrt15.o sqrt16.o sqrt17.o srqt01.o srqt02.o srqt03.o srzt01.o srzt02.o sspt01.o ssyt01.o stbt02.o stbt03.o stbt05.o stbt06.o stpt01.o stpt02.o stpt03.o stpt05.o stpt06.o strt01.o strt02.o strt03.o strt05.o strt06.o stzt01.o stzt02.o sgennd.o serrvx.o sdrvge.o sdrvsy.o serrge.o sdrvgb.o sdrvpo.o serrsy.o serrpo.o \
../../tmglib_DARWIN.a ../../lapack_DARWIN.a ../../blas_DARWIN.a -o xlintsts && mv xlintsts ../xlintsts
Testing REAL LAPACK linear equation routines
./xlintsts < stest.in > stest.out 2>&1
Ambiguous output redirect.
make[1]: *** [stest.out] Error 1
make: *** [lapack_testing] Error 2


please help
shubham111gupta
 
Posts: 6
Joined: Wed Aug 31, 2011 8:45 am

Re: Problem building LAPACK 3.3.1 on Mac LION

Postby cottrell » Sat Sep 03, 2011 9:20 pm

./xlintsts < stest.in > stest.out 2>&1
Ambiguous output redirect.


Looks to me like a bug in the shell on Lion. That redirect is quite
standard. What shell are you using?
cottrell
 
Posts: 68
Joined: Thu Jan 15, 2009 1:40 pm

Re: Problem building LAPACK 3.3.1 on Mac LION

Postby cottrell » Sun Sep 04, 2011 7:16 pm

Follow-up: the most likely cause of this error is that you are using a
*csh shell variant. So:

1) If you are in fact using bash on Lion, and you got this error, it's an
Apple bug, report it to them.

2) Otherwise, if some sort of *csh is the default on Lion, that too is a
bug that you should report to Apple, since many Makefiles depend on
bash-type syntax; but

3) If you have chosen to run a *csh variant yourself, you're on your own.
Using csh is an (obsolete) "expert" option, and it may reasonably be
assumed that if you run into this sort of problem you know how to fix it
yourself.
cottrell
 
Posts: 68
Joined: Thu Jan 15, 2009 1:40 pm

Re: Problem building LAPACK 3.3.1 on Mac LION

Postby shubham111gupta » Sun Sep 11, 2011 8:55 am

Sorry very late reply

Yes I am using csh

I will try it on bash
shubham111gupta
 
Posts: 6
Joined: Wed Aug 31, 2011 8:45 am


Return to User Discussion

Who is online

Users browsing this forum: Bing [Bot], Yahoo [Bot] and 3 guests