Scalapack/BLACS Typemismatch warning / blacs_* fails somet

Post here if you have a question about the installation process

Scalapack/BLACS Typemismatch warning / blacs_* fails somet

Postby C_Clear » Fri Jan 18, 2013 7:05 am

Hello ,
I have a Problem with my Installation of ScaLapack.
I have successfully compiled with the ScaLapack Installer using gcc 4.6.2 (needed bei the ACML Blas).
But while compilation multiple of the following Warning occur .
Code: Select all
Warning: Type mismatch in argument 'erribuf' at (1); passed REAL(8) to INTEGER(4)
blacstest.f:20185.37:

     $                               MEM(ERRIPTR), MEM(ERRDPTR), ISEED)
                                     1



But my Scalapack Library is build at the end.

I use that Library then to link like
Code: Select all
mpic++ -o matrix -lgfortran matrix.o stage.o dSFMT.o ../acml_scalapack_lib/libscalapack.a ../acml_scalapack_lib/libacml.a


I have tried to run my code locally on my machine and i succeed.
At my workplace we use gridengine to submit jobs to our cluster.
As long as i specify less then about 50 nodes ,my program exits as predicted (created matrices/using pzgesv to solve).
When i use much more nodes (400) the job fails giving me the error messages from many nodes:
Code: Select all

[lxb855:13299] *** Process received signal ***
[lxb855:13299] Signal: Segmentation fault (11)
[lxb855:13299] Signal code: Address not mapped (1)
[lxb855:13299] Failing at address: 0x2b11aac6a68c
[lxb855:13299] [ 0] /lib/libpthread.so.0(+0xeff0) [0x2b687ab56ff0]
[lxb855:13299] [ 1] /usr/lib/openmpi/lib/openmpi/mca_btl_sm.so(+0x427c) [0x2b687e82127c]
[lxb855:13299] [ 2] /usr/lib/libopen-pal.so.0(opal_progress+0x5a) [0x2b6879b4918a]
[lxb855:13299] [ 3] /usr/lib/openmpi/lib/openmpi/mca_grpcomm_bad.so(+0x1a15) [0x2b687c329a15]
[lxb855:13299] [ 4] /usr/lib/libmpi.so.0(+0x391d2) [0x2b68796731d2]
[lxb855:13299] [ 5] /usr/lib/libmpi.so.0(MPI_Init+0x170) [0x2b6879694070]
[lxb855:13299] [ 6] matrix(blacs_pinfo_+0xbd) [0x415cfd]
[lxb855:13299] [ 7] matrix(_ZN6SolverC2Ei+0x115) [0x4139ab]
[lxb855:13299] [ 8] matrix(main+0x89) [0x40ef4a]
[lxb855:13299] [ 9] /lib/libc.so.6(__libc_start_main+0xfd) [0x2b687ad82c8d]
[lxb855:13299] [10] matrix() [0x40ec49]
[lxb855:13299] *** End of error message ***
---------------------------------------------------------------------


I am unsure why this behaviour occurs but since it always hangs in some "blacs_*"
routine(like [lxb855:13299] [ 6] matrix(blacs_pinfo_+0xbd) [0x415cfd]) I think it might have something to do with my BLACS installment.



I dont really know how to handle this .
How can I fix this?
thanks in Advance
Attachments
SLmake.txt
My SLmake.inc
(1.48 KiB) Downloaded 73 times
C_Clear
 
Posts: 2
Joined: Tue Oct 30, 2012 4:27 am
Location: Darmstadt/Germany

Return to Installation

Who is online

Users browsing this forum: No registered users and 2 guests