Scalapack 2.0.2 and OpenMPI 1.10.1-- not working?

Post here if you have a question about the installation process

Scalapack 2.0.2 and OpenMPI 1.10.1-- not working?

Postby SpicyBroseph » Tue Jan 19, 2016 2:34 pm

Hello,

Has anybody successfully built Scalapack 2.0.2 with OpenMPI version greater than 1.6.5? I have tried it with both 1.8.5 and 1.10.1 and all the tests fail, but when I compile it with 1.6.5 all the tests pass. Is there some flag I should be using with newer versions of OpenMPI (compiling with gcc 4.8.2 on CentOS 6.7) to get this to work?

Thanks-- I'm trying to get this going so I can compile Mumps with it, and then Elmer.

Nick
SpicyBroseph
 
Posts: 2
Joined: Tue Jan 19, 2016 12:56 pm

Re: Scalapack 2.0.2 and OpenMPI 1.10.1-- not working?

Postby SpicyBroseph » Wed Jan 20, 2016 11:21 am

OK-- I 'fixed' it.

Sorry for crying wolf-- as usual, user error cannot be accounted for

I generally compile/build as a non-root user and then su to make install. Well-- I was trying to run the tests as root (right before installing it) which new flavors of OpenMPI do not let you do unless explicitly stating "--allow-run-as-root" with mpirun. So I did a 'make check' as non-root and it worked.

In order to figure out the problem I had to run ctest -VV --force-new-ctest-process to force the 'very verbose' setting to tell me why the tests were failing so I could see that OpenMPI was complaining. Perhaps including something showing why the tests failed (like "Writing test output to testout.txt") would help?
SpicyBroseph
 
Posts: 2
Joined: Tue Jan 19, 2016 12:56 pm


Return to Installation

Who is online

Users browsing this forum: No registered users and 2 guests

cron