Page 1 of 1

LAPACK version error in scalapack_installer

PostPosted: Thu Jan 25, 2018 7:44 pm
by loriordan
Hi everybody,

I have found an issue when attempting to use the Python based ScaLAPACK Installer with --downall. It expects
the latest version of LAPACK (3.8.0) but the TAR file it pulls down is currently v3.7.1 (scripts/lapack.py:L25 : lapackurl = "http://www.netlib.org/lapack/lapack.tgz").

I imagine the file at this URL needs to be updated to 3.8.0, or a different URL is to be given.
While this is a small issue, it currently breaks our automated installation without patching the python file to search for the v3.7.1 directory ( scripts/lapack.py:L258 : os.chdir(os.path.join(os.getcwd(),'lapack-3.8.0')) )

I tried emailing this to scalapack@eecs.utk.edu but the mail was immediately sent back to me. Anybody here have any recommendations on who to contact?
Thanks in advance!

Re: LAPACK version error in scalapack_installer

PostPosted: Thu Jan 25, 2018 10:00 pm
by admin
Thanks for reporting the issue,
Could you try again and let me know if this works now.
Julie

Re: LAPACK version error in scalapack_installer

PostPosted: Fri Jan 26, 2018 8:31 pm
by loriordan
Hi Julie,
It's working on my end. Thanks for the rapid response and fix.
Lee