building Scalapack with intel MKL

Open discussion regarding features, bugs, issues, vendors, etc.

building Scalapack with intel MKL

Postby georgia8 » Mon Oct 07, 2013 5:31 pm

I have been trying to build Scalapack with intel MKL (Cluster Studio XE, 2013) and although Scalapack builds fine, I get segmentation faults in my program when using it. If I just use the scalapack library provided by intel it works fine - can you say if this is supposed to work / what the problem might be?

To build scalapack I download the installer and do:
./ --prefix=$PWD --mpibindir=$MPIBINDIR --blaslib=$BLASLIB --lapacklib=$LAPACKLIB --fcflags=-g --ccflags=-g --notesting

To build my application I use:
-L$(TACC_FFTW2_LIB) -lfftw \
-L$(TACC_MKL_LIB)/lib/intel64 -lmkl_intel_lp64 \
-L$(INSTALLED_SCALAPACK)/lib -lscalapack \
-lmkl_sequential -lmkl_core -lpthread \
-lmkl_lapack95_lp64 -lmkl_blas95_lp64 -lm \
-L$(UUID_LIB_DIR) -luuid \
-Bstatic \
-L$(XERCESCDIR)/lib -lxerces-c \

when I run the application I get a segmentation fault:
#0 0x00002aaaab1ec6b3 in zdotc_ () from /shared/apps/rhel-6.2/intel/ics-2013/mkl/lib/intel64/
#1 0x00000000006735f4 in pzpotf2 (uplo='l', n=560, a=..., ia=1, ja=1, desca=..., info=0, _uplo=1) at pzpotf2.f:303
#2 0x00000000005ef308 in pzpotrf (uplo='l', n=560, a=..., ia=1, ja=1, desca=..., info=0, _uplo=0) at pzpotrf.f:304

I have also tried downloading lapack and blas and building from those but that also causes a segmentation fault. Again, if I just use the intel verison of scalapack, everything works fine (ofcourse, I would like to compile Scalapack instead, since I wanted to modify some files).

any input is greatly appreciated,
thank you!
Posts: 1
Joined: Mon Oct 07, 2013 2:21 pm

Return to User Discussion

Who is online

Users browsing this forum: Google [Bot] and 6 guests