BLACS installation

Post here if you have a question about the installation process

BLACS installation

Postby ejspeiro » Wed Sep 26, 2012 11:42 am

Hello guys,

this is my first time posting in these forums! Please feel free to let me know if I am doing something wrong :)

I am trying to install BLACS in my local Linux cluster "Dulcinea". I have edited my "Bmake.inc" file as accurate as I could, but I am getting the following error when building:

Code: Select all
[ejspeiro@dulcinea BLACS]$ make all
( cd SRC/MPI ; make  )
make[1]: Entering directory `/usr/sdc/sdc1/home/ejspeiro/libraries/BLACS/SRC/MPI'
( cd INTERNAL ; make -f ../Makefile I_int "dlvl=/home/ejspeiro/libraries/BLACS" )
make[2]: Entering directory `/usr/sdc/sdc1/home/ejspeiro/libraries/BLACS/SRC/MPI/INTERNAL'
gfortran -c  -O bi_f77_mpi_attr_get.f
Error: Can't open included file 'mpif-common.h'
make[2]: *** [bi_f77_mpi_attr_get.o] Error 1
make[2]: Leaving directory `/usr/sdc/sdc1/home/ejspeiro/libraries/BLACS/SRC/MPI/INTERNAL'
make[1]: *** [INTERN] Error 2
make[1]: Leaving directory `/usr/sdc/sdc1/home/ejspeiro/libraries/BLACS/SRC/MPI'
make: *** [MPI] Error 2
[ejspeiro@dulcinea BLACS]$


0k... when I analyze the output, I notice that in the compiling stage, and for some reason, the makefiles are NOT providing the path to the include folder in where the missing file (mpif-common.h) is located at.

I want to ask first before trying to "hack" the makefiles structures, because I recall having installed this library in another local cluster I have access to, and I recall having been able to do it without any problems.

Any hints?

Thanks in advanced!

PS: If necessary, I shall post my Bmake.inc file.
ejspeiro
 
Posts: 18
Joined: Wed Sep 26, 2012 11:30 am
Location: San Diego, CA

Re: BLACS installation

Postby admin » Wed Sep 26, 2012 11:44 am

Hi,
You should give it a try to the ScaLAPACK installer. It will install BLAS (if needed), LAPACK, BLACS and ScaLAPACK.
http://www.netlib.org/scalapack/#_scala ... _for_linux

Otherwise, it just seems that you are missing the path to the MPI include files.
Julie
admin
Site Admin
 
Posts: 502
Joined: Wed Dec 08, 2004 7:07 pm


Return to Installation

Who is online

Users browsing this forum: No registered users and 0 guests

cron