Search found 5 matches

by eweckert
Wed Apr 30, 2014 4:49 pm
Forum: User discussion
Topic: magma-1.4.0-beta2: numerical problems [dz]getrf
Replies: 7
Views: 4066

Re: magma-1.4.0-beta2: numerical problems [dz]getrf

Hi,

latest update. The problem persisted also for a new card. Since I install CUDA-6.0 the errors reported above have disappeared for magma-1.4.1 and above.

Edgar
by eweckert
Mon Jul 22, 2013 6:51 am
Forum: User discussion
Topic: magma-1.4.0-beta2: numerical problems [dz]getrf
Replies: 7
Views: 4066

Re: magma-1.4.0-beta2: numerical problems [dz]getrf

Hi, I did some further tests. I'm able to avoid the error on the GeForce Titan, if I force [sd]getrf_m not to allocate more than about 4.5 GB of RAM on the GPU by faking the freeMem variable accordingly. For some reason [cz]getrf_m never allocate GPU-RAM over these critical barrier. That's probably ...
by eweckert
Tue Jul 16, 2013 7:59 am
Forum: User discussion
Topic: magma-1.4.0-beta2: numerical problems [dz]getrf
Replies: 7
Views: 4066

Re: magma-1.4.0-beta2: numerical problems [dz]getrf

Thanks for looking into that issue. On M2090 all [scdz]getrf tests with large matrices run perfect now in single as well as in multiple GPU configurations. On a single GeForce Titan testing_[scz]getrf produce no errors, however, testing_dgetrf still produces errors for certain matrix sizes. Please s...
by eweckert
Mon Jul 01, 2013 5:04 pm
Forum: User discussion
Topic: magma-1.4.0-beta2: numerical problems [dz]getrf
Replies: 7
Views: 4066

Re: magma-1.4.0-beta2: numerical problems [dz]getrf

Hi, thanks for investigating, please find checks with -c below. Edgar ./testing_dgetrf -c --range 21568:30912:1024 MAGMA 1.4.0 device 0: GeForce GTX TITAN, 875.5 MHz clock, 6143.7 MB memory, capability 3.5 device 1: GeForce GTX 580, 1620.0 MHz clock, 1535.7 MB memory, capability 2.0 device 2: GeForc...
by eweckert
Sun Jun 30, 2013 11:10 am
Forum: User discussion
Topic: magma-1.4.0-beta2: numerical problems [dz]getrf
Replies: 7
Views: 4066

magma-1.4.0-beta2: numerical problems [dz]getrf

Dear all, I get numerical problems for larger matrices using testing_dgetrf and testing_zgetrf. From a certain size on accuracy drops by several orders of magnitude. First I thought about hardware errors but e.g. testing_dpotrf seems to work perfectly for the same matrix size. The error occurs both ...