Search found 7 matches

by danilo
Fri Mar 25, 2011 4:02 am
Forum: User discussion
Topic: Performance of data transfers to GPU
Replies: 10
Views: 7805

Re: Performance of data transfers to GPU

Hi John, I definitely suggest you to use pinned memory for such situations. I had a similar problem in conjugate gradient algorithm, where for each iteration (until convergence) you need to invoke gpu kernels and transfer data from cpu to gpu and vice-versa. Using cudamallochost I obtained good impr...
by danilo
Sun Nov 15, 2009 9:25 am
Forum: User discussion
Topic: Using MAGMA without Intel MKL
Replies: 13
Views: 39609

Re: Using MAGMA without Intel MKL

Hi, yes it's possible! You have to modify the make.inc file in the main directory. If you download magma you'll see different make.inc file for different commercial LAPACK and BLAS (gotoBlas, Atlas, ACML, MKL, ecc..). These are only few examples and if you have different BLAS or LAPACK installed on ...
by danilo
Fri Oct 30, 2009 9:45 am
Forum: User discussion
Topic: Some questions on testing_sgetrf
Replies: 7
Views: 20345

Re: Some questions on testing_sgetrf

Hi Stan, this is my hardware situation: PC1 - Notebook - Ubuntu 9-32bit - Nvidia 8400M-GS --> compilation OK, "magma_sgetrf" gives LU matrix with many Nan and Inf values. The other functions "magma_sgeqrf" and "magma_spotrf" RUN PERFECTY (I think, because the error is very low, comparable to the res...
by danilo
Fri Oct 30, 2009 5:46 am
Forum: User discussion
Topic: Some questions on testing_sgetrf
Replies: 7
Views: 20345

Re: Some questions on testing_sgetrf

Hi, another feedback: I also install cuda 2.3 with 190.xx driver, I tried magma as with standard lapack and blas as with ACML Package using included make.inc. No compilation error, but when I run "testing_sgetrf" I have Nan as result of "get_LU_error" function. I tried also "testing_sgetrf_gpu" and ...
by danilo
Thu Oct 29, 2009 6:56 pm
Forum: User discussion
Topic: Some questions on testing_sgetrf
Replies: 7
Views: 20345

Re: Some questions on testing_sgetrf

Hi, thanks Stan for your reply. I solved the first problem updating the drivers to 185.xx (I'm using CUDA 2.2). But I have not already resolved the second problem. magma_sgetrf seems not working properly and it gives wrong results. I have too high values for error and the output is Nan. Where is the...
by danilo
Thu Oct 29, 2009 12:21 pm
Forum: User discussion
Topic: Some questions on testing_sgetrf
Replies: 7
Views: 20345

Re: Some questions on testing_sgetrf

I add some informations: I run code on Ubuntu 9 - 32 bit. I use standard lapack and blas downloaded with package manager Synaptic. I have no compilation error and the NaN result I obtain is due to very high value returned from residual parameter in "get_LU_error". If I modify the code in order to di...
by danilo
Thu Oct 29, 2009 6:31 am
Forum: User discussion
Topic: Some questions on testing_sgetrf
Replies: 7
Views: 20345

Some questions on testing_sgetrf

Hi, i'm trying Magma, in particolular I have 2 questions on the example testing_sgetrf. 1) I use two different GPU, 8400m GS and 9500GT. The program runs ok on 9500GT but when I try it on 8400m GS I have a segmentation fault (note that I run examples with -N 128 because the small memory of this GPU)...