Search found 203 matches

by fletchjp
Tue Jul 28, 2015 12:29 pm
Forum: User discussion
Topic: JDQZ method for the generalized eigenvalue problem
Replies: 2
Views: 789

Re: JDQZ method for the generalized eigenvalue problem

Hartwig Thank you for your response I have been working with a colleague on large problems from fluid mechanics with dense matrices. We have successfully worked using Arpack and can use Magma to speed up the LAPACK calculations we need. The JDQZ code uses a lot of LAPACK and BLAS, so a Magma version...
by fletchjp
Tue Jul 28, 2015 4:50 am
Forum: User discussion
Topic: JDQZ method for the generalized eigenvalue problem
Replies: 2
Views: 789

JDQZ method for the generalized eigenvalue problem

Are you looking at the JDQZ for MAGMA? This is a method for the solution of the generalised eigenvalue problem for a small no of eigenvalues. It uses GMRES and optionally BiCGstab internally. I was recommended to look at it and have only recently found the code at http://www.win.tue.nl/casa/research...
by fletchjp
Sat Jul 25, 2015 5:44 pm
Forum: User discussion
Topic: Meta site for this forum
Replies: 2
Views: 672

Re: Meta site for this forum

One suggestion I can make is to look at the list of members and sort by the number of posts. There are only a few pages of people who have double figures for the number of posts.

John
by fletchjp
Fri Jul 24, 2015 7:49 am
Forum: User discussion
Topic: Installation MAGMA for CUDA 6.5 on UBUNTU 12.04 X64
Replies: 3
Views: 2194

Re: Installation MAGMA for CUDA 6.5 on UBUNTU 12.04 X64

Please help with advice to get CUDA 6.5 working on Ubuntu 12.04. The problem is with getting the NVIDIA driver to load. I am very pleased to find that Konstantinos has a working system: Dear Sir/Madam, The data of the machine x64 and CUDA in my project are the following. ----------------------------...
by fletchjp
Thu Jul 23, 2015 5:49 am
Forum: User discussion
Topic: Test routines for the sparse matrix methods in 1.6.2
Replies: 5
Views: 1790

Re: Test routines for the sparse matrix methods in 1.6.2

Hartwig

Thank you for that. I am going to upgrade to CUDA 6.5.

I can also upgrade my Ubuntu to 14.04 but that is a big step which can disrupt other things I am doing. I think I do need to do it at some point.

Thanks again

John
by fletchjp
Wed Jul 22, 2015 5:44 pm
Forum: User discussion
Topic: Test routines for the sparse matrix methods in 1.6.2
Replies: 5
Views: 1790

Re: Test routines for the sparse matrix methods in 1.6.2

Hartwig Thank you. My system is a GTX 460, which is a Fermi. My operating system is Ubuntu 12.04 although I do have more recent compilers than gcc 4.6 which is the default. At present I am using CUDA 4.1 and compile using gcc 4.5. Rather to my surprise that will run both MAGMA 1.5.0 and 1.6.2 for mo...
by fletchjp
Wed Jul 22, 2015 1:43 pm
Forum: User discussion
Topic: Test routines for the sparse matrix methods in 1.6.2
Replies: 5
Views: 1790

Re: Test routines for the sparse matrix methods in 1.6.2

I have now found that the sparse methods are in a folder sparse-iter and not built by default.

I can see from a failure that I need routines with names starting cusparse. What version of CUDA do I need for this?

I am currently using CUDA 4.1 which I guess is not up to date enough.

Thanks

John
by fletchjp
Wed Jul 22, 2015 1:29 pm
Forum: User discussion
Topic: Test routines for the sparse matrix methods in 1.6.2
Replies: 5
Views: 1790

Test routines for the sparse matrix methods in 1.6.2

Are there any test routines or examples available for the magma sparse routines in Magma 1.6.2?

I am particularly interesting in calling from FORTRAN and there seem to be few examples of anything for this.

Is there guidance for calling the C or C++ routines from FORTRAN?

Thanks

John
by fletchjp
Thu Oct 02, 2014 3:45 pm
Forum: User discussion
Topic: Magma 1.5.0 Compiler requirements on Ubuntu
Replies: 5
Views: 3249

Re: Magma 1.5.0 Compiler requirements on Ubuntu

I have found a way ahead without (yet) updating cuda. After loading gfortran-4.5 I can get nvcc to work by adding -ccbin /usr/bin/gfortran-4.5 to the NVCC line in make.inc.

That is currently building.

Thanks

John
by fletchjp
Thu Oct 02, 2014 3:33 pm
Forum: User discussion
Topic: Magma 1.5.0 Compiler requirements on Ubuntu
Replies: 5
Views: 3249

Re: Magma 1.5.0 Compiler requirements on Ubuntu

Apologies, the last post was before I had read your reply. Makefile is attached as make.inc.txt. The error message is below. fletcher@fletcher-desktop:~/magma-1.5.0$ make compile for CUDA arch 2.x (Fermi) ======================================== magmablas ( cd magmablas && make ) make[1]: Entering d...