Search found 18 matches

by brom
Wed Feb 23, 2011 11:40 am
Forum: User discussion
Topic: magma_dsytrd questions
Replies: 25
Views: 8748

Re: magma_dsytrd questions

[...] probably in the paper they compare 1 CPU core/thread against 1 GPU. [...] Anyway, are you using a multithreaded LAPACK library CPU side? The paper claims they are using "MKL's parallel BLAS" with "MKL 10.0". I'm using MKL as well. I'd think that hindering the multi-core BLAS would hurt the GP...
by brom
Wed Feb 23, 2011 11:00 am
Forum: User discussion
Topic: magma_dsytrd questions
Replies: 25
Views: 8748

Re: magma_dsytrd questions

I ran the bidiagonalization (SGEBRD) described in that paper as well. I'm seeing a similar discrepancy. M N CPU GFlop/s GPU GFlop/s |A-QHQ'|/N|A| |I-QQ'|/N ================================================================== 1024 1024 8.42 9.09 2048 2048 12.82 14.43 3072 3072 14.09 24.53 4032 4032 13....
by brom
Tue Feb 22, 2011 6:28 pm
Forum: User discussion
Topic: magma_dsytrd questions
Replies: 25
Views: 8748

Re: magma_dsytrd questions

I'm seeing similar results. I had to edit your example, though, removing the d_work parameter. magma_dsytrd(uplo, N, h_R, lda, h_DR, h_ER, h_TAUR, h_WORKR, &LWORKR, d_work, &info); to magma_dsytrd(uplo, N, h_R, lda, h_DR, h_ER, h_TAUR, h_WORKR, &LWORKR, &info); DSYTRD Results: M N CPU GFlop/s GPU GF...
by brom
Mon Jan 31, 2011 5:10 pm
Forum: User discussion
Topic: testing_zgesvd segmentation fault in V1.0 RC3 with mkl10.3
Replies: 8
Views: 6314

Re: testing_zgesvd segmentation fault in V1.0 RC3 with mkl10

"can not bind to texture" is a CUDA error that happens when, well, a texture can't be bound. usually due to hardware limitations.
by brom
Mon Jan 31, 2011 1:21 pm
Forum: User discussion
Topic: Error testing magma-rc3 with mkl
Replies: 3
Views: 2764

Re: Error testing magma-rc3 with mkl

As an update, I have successfully linked against MKL 10.2.

It would be nice to use MKL 10.3, though as there are many optimizations for the latest Intel hardware in that release! However, 10.3 still gives segmentation faults or random hangs for every test.
by brom
Fri Jan 28, 2011 12:43 pm
Forum: User discussion
Topic: testing_zgesvd segmentation fault in V1.0 RC3 with mkl10.3
Replies: 8
Views: 6314

Re: testing_zgesvd segmentation fault in V1.0 RC3 with mkl10

This seg faults for me too using Atlas (still can't compile with MKL).
by brom
Fri Jan 28, 2011 12:13 pm
Forum: User discussion
Topic: Error testing magma-rc3 with mkl
Replies: 3
Views: 2764

Re: Error testing magma-rc3 with mkl

I'm using MKL 10.3.1.107 which doesn't have a number of the libraries in your MKL make file. I think Intel has changed some of their naming conventions and removed libguide.so at least.
by brom
Tue Jan 25, 2011 8:27 pm
Forum: User discussion
Topic: Error testing magma-rc3 with mkl
Replies: 3
Views: 2764

Error testing magma-rc3 with mkl

I'm having trouble testing with MKL's BLAS. I'm able to compile and link just fine. However, the tests just stall endlessly. Additionally, a number of tests get an error saying:

MKL ERROR: Parameter 7 was incorrect on entry to DGEQRF

This is RC3 and MKL 10.3.