clmagma: error: must specify '#pragma OPENCL EXTENSION cl_k

Open discussion for MAGMA

clmagma: error: must specify '#pragma OPENCL EXTENSION cl_k

Postby vish108 » Fri Aug 08, 2014 1:51 pm

Hi All,

I am trying to install clmagma on a machine with an Nvidia GPU. As you can see in the error listing, clMagma does detect the GPU device (GRID K520), but I get an error.

Code: Select all
./clcompile zlarfgx-v2.cl
Initializing...
Device: GRID K520
clBuildProgram error at 1051 in CL_MAGMA_RT.cpp
In file included from :11:
./kernels_header.h:30:15: error: must specify '#pragma OPENCL EXTENSION cl_khr_fp64: enable' before using 'double'
doubleComplex(double real, double imag)
              ^

./clcompile zlarfx.cl
Initializing...
Device: GRID K520
clBuildProgram error at 1051 in CL_MAGMA_RT.cpp
In file included from :12:
./kernels_header.h:30:15: error: must specify '#pragma OPENCL EXTENSION cl_khr_fp64: enable' before using 'double'
doubleComplex(double real, double imag)
              ^


I am not sure what I have done wrong.

Sincerely,

Vishal
vish108
 
Posts: 16
Joined: Mon Feb 03, 2014 6:05 pm

Re: clmagma: error: must specify '#pragma OPENCL EXTENSION

Postby mgates3 » Wed Aug 13, 2014 11:16 am

You could try adding that line to kernels_header.h. This is something we've never seen.

#pragma OPENCL EXTENSION cl_khr_fp64: enable

But again, we strongly suggest using the CUDA version of MAGMA on CUDA GPUs.

-mark
mgates3
 
Posts: 407
Joined: Fri Jan 06, 2012 2:13 pm


Return to User discussion

Who is online

Users browsing this forum: Google [Bot] and 1 guest