Error testing dsgesv and zcgesv

Open discussion for MAGMA

Error testing dsgesv and zcgesv

Postby fletchjp » Mon Dec 27, 2010 7:45 pm

I have installed MAGMA 1.0 RC2 on a system running Ubuntu Linux 10.4 (64 bit) and have CUDA 3.2 installed.
I have an 8 core CPU and 8 Gbytes of main memory. The GPU reports as follows:
device 0: GeForce GTX 460, 1400.0 MHz clock, 2047.2 MB memory
I am using gcc and gfortran and have GotoBLAS2 installed.

I have been testing MAGMA routines and many work. testing_dsgesv_gpu and testing_zcgesv fail with the following message:

device 0: GeForce GTX 460, 1400.0 MHz clock, 2047.2 MB memory

Usage:
testing_zcgesv_gpu -nrhs 1 -N 1024

Epsilon(double): 1.110223e-16
Epsilon(single): 5.960464e-08

N DP-Factor DP-Solve SP-Factor SP-Solve MP-Solve ||b-Ax||/||A|| NumIter
==================================================================================
1024MAGMA Error: On Routine magma_zcgesv argument number -4200715 had an illegal value

I deduced from some tests that this is because info is unset on exit from the routines. I have "fixed" this by setting *info = 0 at the start of the routines, but this is clearly just covering up a lack of correct reporting somewhere further on.
The routines then run.

I wanted to get this to you quickly as you are still in RC status.

I hope this helps.

I can report my results if that is useful.

Thank you for your efforts on this.

John Fletcher
fletchjp
 
Posts: 170
Joined: Mon Dec 27, 2010 7:29 pm

Re: Error testing dsgesv and zcgesv

Postby Stan Tomov » Mon Jan 03, 2011 12:13 am

Thanks for this report. We corrected the problems. The fixes will be available by the end of the week in MAGMA 1.0 RC3.
Stan Tomov
 
Posts: 249
Joined: Fri Aug 21, 2009 10:39 pm


Return to User discussion

Who is online

Users browsing this forum: No registered users and 2 guests

cron