Problem with -lifcore

Open discussion for MAGMA library (Matrix Algebra on GPU and Multicore Architectures)
Post Reply
echse
Posts: 15
Joined: Thu May 28, 2015 9:59 am

Problem with -lifcore

Post by echse » Thu May 28, 2015 10:13 am

Hi,

I hope someone can help me. I've got the following problem, when I try to compile Magma:

compile for CUDA arch 2.x (Fermi)
compile for CUDA arch 3.0 (Kepler)
compile for CUDA arch 3.5 (Kepler)
======================================== magmablas
( cd magmablas && make )
make[1]: Verzeichnis »/home/tobi/Programme/magma-1.6.2/magmablas« wird betreten
make[1]: Für das Ziel »all« ist nichts zu tun.
make[1]: Verzeichnis »/home/tobi/Programme/magma-1.6.2/magmablas« wird verlassen
======================================== src
( cd src && make )
make[1]: Verzeichnis »/home/tobi/Programme/magma-1.6.2/src« wird betreten
make[1]: Für das Ziel »all« ist nichts zu tun.
make[1]: Verzeichnis »/home/tobi/Programme/magma-1.6.2/src« wird verlassen
======================================== control
( cd control && make )
make[1]: Verzeichnis »/home/tobi/Programme/magma-1.6.2/control« wird betreten
make[1]: Für das Ziel »all« ist nichts zu tun.
make[1]: Verzeichnis »/home/tobi/Programme/magma-1.6.2/control« wird verlassen
======================================== interface
( cd interface_cuda && make )
make[1]: Verzeichnis »/home/tobi/Programme/magma-1.6.2/interface_cuda« wird betreten
make[1]: Für das Ziel »all« ist nichts zu tun.
make[1]: Verzeichnis »/home/tobi/Programme/magma-1.6.2/interface_cuda« wird verlassen

======================================== testing
( cd testing && make )
make[1]: Verzeichnis »/home/tobi/Programme/magma-1.6.2/testing« wird betreten
gcc -fopenmp -Wl,-rpath,../lib testing_zgeqp3.o -o testing_zgeqp3 \
libtest.a lin/liblapacktest.a -L../lib -lmagma \
-L/usr/local/cuda/lib64 -L/home/tobi/Programme/lib -L/usr/local/atlas/lib \
-llapack -lf77blas -lcblas -latlas -lcublas -lcudart -lstdc++ -lm -lgfortran -lifcore
/usr/bin/ld: cannot find -lifcore
collect2: error: ld returned 1 exit status
make[1]: *** [testing_zgeqp3] Fehler 1
make[1]: Verzeichnis »/home/tobi/Programme/magma-1.6.2/testing« wird verlassen
make: *** [test] Fehler 2


Here is my make.inc-file:

#//////////////////////////////////////////////////////////////////////////////
# -- MAGMA (version 1.6.1) --
# Univ. of Tennessee, Knoxville
# Univ. of California, Berkeley
# Univ. of Colorado, Denver
# @date January 2015
#//////////////////////////////////////////////////////////////////////////////

# GPU_TARGET contains one or more of Tesla, Fermi, or Kepler,
# to specify for which GPUs you want to compile MAGMA:
# Tesla - NVIDIA compute capability 1.x cards (no longer supported in CUDA 6.5)
# Fermi - NVIDIA compute capability 2.x cards
# Kepler - NVIDIA compute capability 3.x cards
# The default is "Fermi Kepler".
# See http://developer.nvidia.com/cuda-gpus
#
#GPU_TARGET ?= Fermi Kepler

CC = gcc
CXX = g++
NVCC = nvcc
FORT = gfortran

ARCH = ar
ARCHFLAGS = cr
RANLIB = ranlib

# Use -fPIC to make shared (.so) and static (.a) library;
# can be commented out if making only static library.
##
## Our ATLAS installation has only static libraries, and one can't
## build a shared library against a static library, so disable FPIC.
##FPIC = -fPIC

CFLAGS = -O3 $(FPIC) -DADD_ -Wall -fopenmp -DMAGMA_SETAFFINITY
FFLAGS = -O3 $(FPIC) -DADD_ -Wall -Wno-unused-dummy-argument
F90FLAGS = -O3 $(FPIC) -DADD_ -Wall -Wno-unused-dummy-argument -x f95-cpp-input
NVCCFLAGS = -O3 -DADD_ -Xcompiler "-fno-strict-aliasing $(FPIC)"
LDFLAGS = $(FPIC) -fopenmp

# Depending on how ATLAS and LAPACK were compiled, you may need one or more of:
# -lifcore -ldl -lf2c -lgfortran
LIB = -llapack -lf77blas -lcblas -latlas -lcublas -lcudart -lstdc++ -lm -lgfortran -lifcore

# define library directories preferably in your environment, or here.
LAPACKDIR = /home/tobi/Programme/lib
ATLASDIR = /usr/local/atlas
CUDADIR = /usr/local/cuda
-include make.check-atlas
-include make.check-cuda

LIBDIR = -L$(CUDADIR)/lib64 \
-L$(LAPACKDIR) \
-L$(ATLASDIR)/lib

INC = -I$(CUDADIR)/include

Post Reply