cannot find -lf77blas

Open discussion for MAGMA library (Matrix Algebra on GPU and Multicore Architectures)

cannot find -lf77blas

Postby robintux » Thu Jan 27, 2011 4:34 pm

I have a tesla C1060 , while compiling the magma_1.0.0-rc3 , the error is :

Code: Select all

make[1]: Entering directory `/home/abraham/magma_1.0.0-rc3/testing'
gcc -O3 -DADD_ -DGPUSHMEM=130 -I/usr/local/cuda/include -I../include -I../quark/include -c testing_zgemm.cpp -o testing_zgemm.o
gfortran -O3 -DADD_ -DGPUSHMEM=130 -fPIC -Xlinker -zmuldefs -DGPUSHMEM=130  testing_zgemm.o  -o testing_zgemm lin/liblapacktest.a -L../lib \
          -lcuda -lmagma -lmagmablas -lmagma -L/usr/lib64/atlas -L/usr/lib/ -L/home/abraham/magma_1.0.0-rc3/CLAPACK- -L/usr/local/cuda/lib64 -L/usr/local/cuda/lib  /usr/lib64/liblapack.a -lf77blas -latlas -lf2c -lcublas -lm
/usr/bin/ld: cannot find -lf77blas
collect2: ld returned 1 exit status
make[1]: *** [testing_zgemm] Error 1
rm testing_zgemm.o
make[1]: Leaving directory `/home/abraham/magma_1.0.0-rc3/testing'
make: *** [test] Error 2

I use ubuntu 10.04 x86_64 . which is the package that I need ????
Posts: 3
Joined: Thu Jan 27, 2011 3:30 pm

Re: cannot find -lf77blas

Postby Stan Tomov » Mon Jan 31, 2011 5:57 pm

You need libf77blas.a. This library should be part of the ATLAS installation so it should have been in /usr/lib64/atlas on your machine. I just tried compiling with ATLAS and everything worked using this
Code: Select all
#   -- MAGMA (version 1.0) --
#      Univ. of Tennessee, Knoxville
#      Univ. of California, Berkeley
#      Univ. of Colorado, Denver
#      November 2010

# GPU_TARGET specifies for which GPU you want to compile MAGMA
#      0: Tesla family
#      1: Fermi Family

CC        = gcc
NVCC      = nvcc
FORT      = gfortran

ARCH      = ar
RANLIB    = ranlib

OPTS      = -O3 -DADD_
NVOPTS    = --compiler-options -fno-strict-aliasing -DUNIX -O3 -DADD_
LDOPTS    = -fPIC -Xlinker -zmuldefs

LIB       = /home/tomov/LIB/lapack-lite-3.1.1/lapack_LINUX64.a \
            -lf77blas -latlas -lcblas -lf2c -lcublas -lm

CUDADIR   = /usr/local/cuda-3.0

LIBDIR    = -L/home/tomov/LIB/ATLAS/lib/Linux_UNKNOWNSSE2 \
            -L/home/tomov/LIB/CLAPACK-3.1.1/F2CLIBS/ \
INC       = -I$(CUDADIR)/include

LIBMAGMA     = ../lib/libmagma.a
LIBMAGMABLAS = ../lib/libmagmablas.a

Libraries libf77blas.a, liblatlas.a, and libcblas.a should come with ATLAS and on my system they were all in /home/tomov/LIB/ATLAS/lib/Linux_UNKNOWNSSE2.

Stan Tomov
Posts: 258
Joined: Fri Aug 21, 2009 10:39 pm

Return to User discussion

Who is online

Users browsing this forum: Bing [Bot] and 3 guests