Help please to get CUDA 6.5 working on Ubuntu 12.04

Open discussion for MAGMA library (Matrix Algebra on GPU and Multicore Architectures)
Post Reply
fletchjp
Posts: 203
Joined: Mon Dec 27, 2010 7:29 pm

Help please to get CUDA 6.5 working on Ubuntu 12.04

Post by fletchjp » Mon Aug 03, 2015 11:22 am

I have the CUDA 6.5 installed but it needs an update of the NVIDIA drivers before it will work.

I have tried once and it crashed the computer as it did not install the correct kernel module and graphics disappeared. Luckily I can log in remotely and used that to backtrack.

I know it has been achieved from another thread. I would like to get advice from anyone else who has succeeded either on Ubuntu 12.04 or 14.04 which is the upgrade path if I have to.

My hardware is intel 64 bit with GTX 460 graphics hardware.

Thanks

John

fletchjp
Posts: 203
Joined: Mon Dec 27, 2010 7:29 pm

Re: Help please to get CUDA 6.5 working on Ubuntu 12.04

Post by fletchjp » Thu Aug 13, 2015 7:12 pm

It would help me very much if anyone with relevant experience could reply on this one.

I tried an update using methods I had used before and the graphics collapsed completely because the correct module was not in place for the kernel.

I was able to log in from another computer and back out of the change. Without that I had no easy path forward.

If you know anything please give me some pointer. I know there are installations which work.

Thanks

John

hartwig anzt
Posts: 90
Joined: Tue Sep 02, 2014 5:44 pm

Re: Help please to get CUDA 6.5 working on Ubuntu 12.04

Post by hartwig anzt » Fri Aug 14, 2015 9:02 am

John,
did you consider updating your ubuntu version? this might be the easier way to go.
Hartwig

fletchjp
Posts: 203
Joined: Mon Dec 27, 2010 7:29 pm

Re: Help please to get CUDA 6.5 working on Ubuntu 12.04

Post by fletchjp » Fri Aug 14, 2015 12:35 pm

Hartwig

Thank you, I have thought of that. I do need to do that eventually. At the moment I have two computers, chosen to have the same graphics card (GTX 460) when they were new. Both are on Ubuntu 12.04. One dual boots to Windows 7 as well. At the moment the dual boot one will only do low res graphics both on Windows and Ubuntu!! I think something is wrong in the grub boot sequence. I don't know how the boot sequence does graphics. I think I need to get this problem sorted before doing anything else.

Any thoughts from anyone would be appreciated.

Thanks

John

P.S. My latest theory is that the graphics card is malfunctioning. Now confirmed by pushing it in firmly! So my apologies for raising my hardware problems on this group.

Post Reply