problem with magma_mic_server

Open discussion for MAGMA library (Matrix Algebra on GPU and Multicore Architectures)

problem with magma_mic_server

Postby ligongzheng » Thu Apr 28, 2016 7:53 am

dear all:
I am going to install the magma mic on TianHe 2 cluster.The steps are as follow:
1.cp make.inc.mkl mkl.inc(I have install MKL before,so I didn't source the environment)
2. ./copy_server_file.sh
3.ssh mic0 and /tmp/launch.sh
The problem came out when I did the step 3. the result was as below:
[img]C:\Users\b306-10\Desktop\222.jpg[/img]

As picture shows,the magma_mic_server get stuck.and I use the ps -aux | grep "MIC" to figure out its status,it shows that the magma_mic_server is sleeping(S+).
So I wonder what problem with this?
Thank you for advance!
ligongzheng
 
Posts: 1
Joined: Thu Apr 28, 2016 7:40 am

Re: problem with magma_mic_server

Postby Stan Tomov » Mon May 09, 2016 2:57 pm

Hi,
This procedure is correct but for the older versions of the MAGMA MIC library (see file INSTRUCTIONS_to_run.txt). The current version is 1.4, and here you don't have to login directly to the MIC and start the server. The MAGMA MIC initialization routine is doing this (copying files to the MIC and starting the server). If the installation is completed without problems, you can test by running any of the testing routines from the 'testing' directory.
Stan Tomov
 
Posts: 258
Joined: Fri Aug 21, 2009 10:39 pm


Return to User discussion

Who is online

Users browsing this forum: Bing [Bot] and 3 guests