Page 1 of 1

Magma 1.7 compatible with SM6.0?

Posted: Sat May 05, 2018 3:34 pm
by ffangliu
Hi everyone! We have some code build with magma1.7 and used to run well. It can also run well on NVIDIA P100 (SM6.0) if magma is off. Recently we found that when magma was turned on, the job failed on P100. I'm wondering whether this is because magma1.7 is too old (released in 2015) and not compatible with SM6.0?

Thanks!

Re: Magma 1.7 compatible with SM6.0?

Posted: Sat May 05, 2018 3:54 pm
by mgates3
Are there particular routines that you are using that are failing? We haven't tested MAGMA 1.7 on a P100, and can't off-hand say what changes may have affected it.

MAGMA 1.7 is rather old. I would recommend seeing if a newer version of MAGMA works. It should not require any code changes. However, in the long term, I would suggest changing from #include <magma.h> to #include <magma_v2.h> to get the newer interface, which mostly affects BLAS routines that now take a queue.

-mark

Re: Magma 1.7 compatible with SM6.0?

Posted: Sat May 19, 2018 2:05 pm
by Danniella
Isnt the latest v2.3? or am i completly wrong?

_____________________________________________________________________________
Sugaring KĂžbenhavn

Re: Magma 1.7 compatible with SM6.0?

Posted: Sat May 19, 2018 3:50 pm
by mgates3
Yes, MAGMA 2.3.0 is the latest. I think the user was asking about an app that hasn't been updated.
-mark