magma installation using intel compiler Version 12.0.2

Open discussion for MAGMA

magma installation using intel compiler Version 12.0.2

Postby joegi » Fri Apr 22, 2011 11:03 am

Hi,

I'm trying to install magma with intel compilers version 12.0.2 and CUDA Toolkit version 3.2, but I am getting the following error, any clue what could be the problem????

joegi@dagobah:~/gpu/magma_1.0.0-rc5> make
( cd control && make )
make[1]: Entering directory `/home/joegi/gpu/magma_1.0.0-rc5/control'
ifort -O3 -DADD_ -Dmagma_devptr_t="integer(kind=8)" -I/usr/local/cuda/include -I../include -I../quark/include -c magma_zfortran.f90 -o magma_zfortran.o
magma_zfortran.f90(11): warning #5117: Bad # preprocessor line
#define PRECISION_z
-^
magma_zfortran.f90(158): warning #5117: Bad # preprocessor line
#if defined(PRECISION_z) || defined(PRECISION_c)
-^
magma_zfortran.f90(211): warning #5117: Bad # preprocessor line
#else
-^
magma_zfortran.f90(259): warning #5117: Bad # preprocessor line
#endif
-^
magma_zfortran.f90(266): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dA
---------------------^
magma_zfortran.f90(268): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dB
---------------------^
magma_zfortran.f90(278): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dA
---------------------^
magma_zfortran.f90(281): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dT
---------------------^
magma_zfortran.f90(288): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dA
---------------------^
magma_zfortran.f90(297): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dA
---------------------^
magma_zfortran.f90(300): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dT
---------------------^
magma_zfortran.f90(308): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dA
---------------------^
magma_zfortran.f90(311): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dT
---------------------^
magma_zfortran.f90(312): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dB
---------------------^
magma_zfortran.f90(323): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dA
---------------------^
magma_zfortran.f90(326): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dT
---------------------^
magma_zfortran.f90(327): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dB
---------------------^
magma_zfortran.f90(341): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dL1
---------------------^
magma_zfortran.f90(343): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dL
---------------------^
magma_zfortran.f90(345): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dA
---------------------^
magma_zfortran.f90(353): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dA
---------------------^
magma_zfortran.f90(356): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dB
---------------------^
magma_zfortran.f90(364): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dA
---------------------^
magma_zfortran.f90(374): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dA
---------------------^
magma_zfortran.f90(377): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dB
---------------------^
magma_zfortran.f90(388): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: da
---------------------^
magma_zfortran.f90(396): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dx
---------------------^
magma_zfortran.f90(400): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dy
---------------------^
magma_zfortran.f90(412): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dv
---------------------^
magma_zfortran.f90(414): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dt
---------------------^
magma_zfortran.f90(416): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dc
---------------------^
magma_zfortran.f90(418): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dowrk
---------------------^
magma_zfortran.f90(426): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dA
---------------------^
magma_zfortran.f90(428): error #5082: Syntax error, found '::' when expecting one of: ( % [ : . = =>
magma_devptr_t:: dB
---------------------^
magma_zfortran.f90(430): catastrophic error: Too many errors, exiting
compilation aborted for magma_zfortran.f90 (code 1)
make[1]: *** [magma_zfortran.o] Error 1
make[1]: Leaving directory `/home/joegi/gpu/magma_1.0.0-rc5/control'
make: *** [libmagma] Error 2
joegi
 
Posts: 1
Joined: Fri Apr 22, 2011 10:59 am

Re: magma installation using intel compiler Version 12.0.2

Postby mateo70 » Thu Apr 28, 2011 8:58 am

Hi,

you just need to add the option to force the compiler to preprocess the fortran files in the FOPTS variable in your make.inc. We didn't change all the extensions to have it automatically, but looking at the number of people having problem with that, we will probably change that in the final release.

You can look at the 3 or 4 other posts on the subject to have more details on the solution.

Mathieu
mateo70
 
Posts: 41
Joined: Tue Mar 08, 2011 12:38 pm

Re: magma installation using intel compiler Version 12.0.2

Postby keyamoon » Sat May 21, 2011 2:38 am

I'm getting the same error with ifort. I searched the forums for other similar topics. None of them helped me :(

I tried using gfortran instead of ifort which got me this error:

Fatal Error: File 'magma_param.mod' opened at (1) is not a GFORTRAN module file

(I installed gfortran using "apt-get install gfortran" on ubuntu 10)

I also tried adding " -x f95-cpp-input" to my FORT variable in my make.inc file but I was still getting the same error that it's not a gfortran module. Should I use a specific version of gfortran?

Is there any solution for ifort?
keyamoon
 
Posts: 1
Joined: Sat May 21, 2011 2:10 am

Re: magma installation using intel compiler Version 12.0.2

Postby mateo70 » Thu May 26, 2011 12:20 pm

Hi,

For gfortran: just remove the .mod file or do a "make cleanall" before to recompile with gfortran. You probably still have the .mod generated by ifort.
For ifort: add the option -fpp after ifort in FORT to force the precompilation of the files.

Mathieu
mateo70
 
Posts: 41
Joined: Tue Mar 08, 2011 12:38 pm

Re: magma installation using intel compiler Version 12.0.2

Postby smul » Fri Jul 15, 2011 2:48 am

Hello,

I had the same problem but the -fpp option sloved it.

Unfortunately a new problem popped up:

nvcc --compiler-options -fno-strict-aliasing -DUNIX -O3 -DADD_ -arch sm_20 -DGPUSHMEM=200 -I/usr/local/cuda/include -I../include -I../quark/include -I../control -c zauxiliary.cu -o zauxiliary.cu_o
/tmp/tmpxft_0000450c_00000000-1_zauxiliary.cudafe1.stub.c: In function 'void __device_stub__Z12zset_to_zeroP7double2i(cuDoubleComplex*, int)':
/tmp/tmpxft_0000450c_00000000-1_zauxiliary.cudafe1.stub.c:7: error: '__cudaSetupArgSimple' was not declared in this scope
/tmp/tmpxft_0000450c_00000000-1_zauxiliary.cudafe1.stub.c: In function 'void __device_stub__Z18zset_nbxnb_to_zeroiP7double2i(int, cuDoubleComplex*, int)':
/tmp/tmpxft_0000450c_00000000-1_zauxiliary.cudafe1.stub.c:1: error: '__cudaSetupArgSimple' was not declared in this scope
/tmp/tmpxft_0000450c_00000000-1_zauxiliary.cudafe1.stub.c: In function 'void __device_stub__Z6zlasetiiP7double2i(int, int, cuDoubleComplex*, int)':
/tmp/tmpxft_0000450c_00000000-1_zauxiliary.cudafe1.stub.c:1: error: '__cudaSetupArgSimple' was not declared in this scope
make[1]: *** [zauxiliary.cu_o] Error 1
make[1]: Leaving directory `/path/to/magma/magmablas'
make: *** [libmagmablas] Error 2

Can some one please help?

smul
smul
 
Posts: 1
Joined: Fri Jul 15, 2011 2:45 am

Re: magma installation using intel compiler Version 12.0.2

Postby Stan Tomov » Mon Jul 25, 2011 11:18 am

Hello,
Sometimes a problem would be several CUDA versions being installed on a system. Check the version of nvcc and the CUDA include files that you have in /usr/local/cuda/include.
Stan
Stan Tomov
 
Posts: 249
Joined: Fri Aug 21, 2009 10:39 pm


Return to User discussion

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Yahoo [Bot] and 2 guests

cron