(d/s)getrf_batched doesn't send back errors

Open discussion for MAGMA library (Matrix Algebra on GPU and Multicore Architectures)
Post Reply
vishwakftw
Posts: 6
Joined: Mon Dec 10, 2018 2:32 am

(d/s)getrf_batched doesn't send back errors

Post by vishwakftw » Mon Dec 10, 2018 2:39 am

Hi,

I'm using MAGMA to perform LU decomposition on batches of matrices. I understand that there are two variants: the pivoting variant and the non-pivoting variants.

The non-pivoting variant seems to return the current info values as expected, whereas the pivoting variant seems to not do this, and hence outputs the infos as 0s even for singular inputs, which I am sure is not correct.

Can someone look into this, and confirm this behavior?

Best,

Vishwak

abdelfattah83
Posts: 3
Joined: Mon Dec 10, 2018 3:02 pm

Re: (d/s)getrf_batched doesn't send back errors

Post by abdelfattah83 » Tue Dec 11, 2018 2:20 pm

This should be fixed now if you update your local copy of the repository. Please test on your side and let us know if the issues are gone.

--Ahmad

vishwakftw
Posts: 6
Joined: Mon Dec 10, 2018 2:32 am

Re: (d/s)getrf_batched doesn't send back errors

Post by vishwakftw » Wed Dec 12, 2018 11:18 am

Hi Ahmad,

Thank you for the prompt response.

Unfortunately, this doesn't seem to resolve the issue, and now the non-pivoting variant is also not working as expected with respect to sending back errors. Furthermore, I think I might have found that the pivot information is also not sent back in the pivoting variant.

Could you please look into this? This is also affecting the batched inverse computation as well.


EDIT: Dec 15, 2018:
I apologize for misinforming, and can confirm that the issues has been resolved. Thank you for looking into this.

abdelfattah83
Posts: 3
Joined: Mon Dec 10, 2018 3:02 pm

Re: (d/s)getrf_batched doesn't send back errors

Post by abdelfattah83 » Mon Dec 17, 2018 10:01 am

Great, thanks for letting us know.

--Ahmad

Post Reply