Error in MAGMA installation

Open discussion for MAGMA library (Matrix Algebra on GPU and Multicore Architectures)

Error in MAGMA installation

Postby ssk87 » Tue Sep 06, 2011 1:15 pm

I try to install MAGMA .
I think everything works well testing

# -- MAGMA (version 1.0) --
# Univ. of Tennessee, Knoxville
# Univ. of California, Berkeley
# Univ. of Colorado, Denver
# November 2010

# GPU_TARGET specifies for which GPU you want to compile MAGMA
# 0: Tesla family
# 1: Fermi Family

CC = icc
NVCC = nvcc
FORT = ifort

ARCH = ar
RANLIB = ranlib

FOPTS = -O3 -DADD_ -cpp
NVOPTS = --compiler-options -fno-strict-aliasing -DUNIX -O3 -DADD_
LDOPTS = -fPIC -nofor_main -Xlinker -zmuldefs

LIB = -lpthread -lcublas -lcudart -lm

CUDADIR = /share/apps/cuda

LIBDIR = -L$(MKLROOT)/lib/intel64 \
INC = -I$(CUDADIR)/include \

LIBMAGMA = ../lib/libmagma.a
LIBMAGMABLAS = ../lib/libmagmablas.a

testing_zgemm.o: In function `main':
testing_zgemm.cpp:(.text+0x91f): undefined reference to `zlarnv_'
testing_zgemm.cpp:(.text+0x944): undefined reference to `zlarnv_'
testing_zgemm.cpp:(.text+0x969): undefined reference to `zlarnv_'
testing_zgemm.cpp:(.text+0xdf4): undefined reference to `zaxpy_'
testing_zgemm.cpp:(.text+0xe26): undefined reference to `zlange_'
../lib/libmagma.a(auxiliary.o): In function `swp2pswp':
auxiliary.cpp:(.text+0x2ba7): undefined reference to `lsame_'
make[1]: *** [testing_zgemm] Error 1
rm testing_zgemm.o
make[1]: Leaving directory `/home/ssk87/magma_1.0.0/testing'
make: *** [test] Error 2

Do any one have idea why this error occurs and how to fix this

Posts: 4
Joined: Tue Sep 06, 2011 12:51 pm

Re: Error in MAGMA installation

Postby Stan Tomov » Thu Sep 08, 2011 3:49 pm

The undefined functions are part of LAPACK which is dependence and has to be installed and added to LIB in You can see and example files (e.g.,
Stan Tomov
Posts: 254
Joined: Fri Aug 21, 2009 10:39 pm

Return to User discussion

Who is online

Users browsing this forum: Bing [Bot] and 1 guest