Windows compile error using Mingw64

Open discussion for MAGMA

Windows compile error using Mingw64

Postby JeffBurnett » Fri Apr 20, 2012 11:17 am

I am trying to compile on 64bit Windows7 using the Mingw64 toolchain and MKL and I get the error below. Note that I removed the -DUNIX directive but didn't replace it with anything.

c:\Users\jeff\local\magma\magma_1.1.0>make
The system cannot find the path specified.
( cd control && make )
The system cannot find the path specified.
make[1]: Entering directory `c:/Users/jeff/local/magma/magma_1.1.0/control'
gcc -O3 -DADD_ -cpp -DGPUSHMEM=200 -IC:/Users/jeff/local/NVIDIAGPUComputingToolk
it/CUDA/v4.1/include -I../include -IC:/Users/jeff/local/magma/magma_1.1.0/quark/
include -c auxiliary.cpp -o auxiliary.o
In file included from C:/Users/jeff/local/NVIDIAGPUComputingToolkit/CUDA/v4.1/in
clude/cuda_runtime_api.h:150:0,
from common_magma.h:27,
from auxiliary.cpp:9:
C:/Users/jeff/local/NVIDIAGPUComputingToolkit/CUDA/v4.1/include/host_defines.h:7
9:0: warning: "__cdecl" redefined [enabled by default]
<built-in>:0:0: note: this is the location of the previous definition
In file included from common_magma.h:49:0,
from auxiliary.cpp:9:
../include/magma_lapack.h:49:35: error: expected ',' or '...' before 'char'
../include/magma_lapack.h:50:35: error: expected ',' or '...' before 'char'
make[1]: *** [auxiliary.o] Error 1
make[1]: Leaving directory `c:/Users/jeff/local/magma/magma_1.1.0/control'
make: *** [libmagma] Error 2

Not sure sure about the first error about not finding the path since it moves on and tries to compile in the control directory.

The relevant lines from magma_lapack.h are below. It is chocking on "small".
Code: Select all
void     lapackf77_slabad(float  *small, float  *large);
void     lapackf77_dlabad(double *small, double *large);


Here is my make.inc file:

Code: Select all
GPU_TARGET = 1
CUDADIR   = C:/Users/jeff/local/NVIDIAGPUComputingToolkit/CUDA/v4.1
MKLROOT = C:/Users/jeff/local/Intel/MKL/10.2.6.037
MAGMA_DIR = C:/Users/jeff/local/magma/magma_1.1.0

CC        = gcc
NVCC      = nvcc
#FORT = ifort -fpp
FORT      = gfortran

ARCH      = ar
ARCHFLAGS = cr
RANLIB    = ranlib

OPTS      = -O3 -DADD_ -cpp
FOPTS     = -O3 -DADD_ -cpp -x f95-cpp-input

NVOPTS    = --compiler-options -fno-strict-aliasing -O3 -DADD_
#NVOPTS    = --compiler-options -fno-strict-aliasing -DUNIX -O3 -DADD_
LDOPTS    = -fPIC -nofor_main -Xlinker -zmuldefs

LIB       = -lmkl_intel_lp64 -lmkl_intel_thread -lmkl_lapack -lmkl_core -lguide -lpthread -lcublas -lcudart -lm

LIBDIR    = -L$(MKLROOT)/lib/intel64 \
            -L$(CUDADIR)/lib64
INC       = -I$(CUDADIR)/include


Any help is appreciated with this. I'm not sure what to try next.

A note to anyone trying to compile on windows: to get the fortran files to compile I manually set PTROPT=-Dmagma_devptr_t="integer(kind=8)" in Makefile.internal. On linux this value is determined by shelling out. Also, I had to include C preprocess directives. For intel fortran set FORT = ifort -fpp, for gfortran set FORT = gfortran -x f95-cpp-input.

Regards,

Jeff
JeffBurnett
 
Posts: 1
Joined: Fri Apr 20, 2012 10:52 am

Return to User discussion

Who is online

Users browsing this forum: Google [Bot] and 3 guests

cron