magma_sgetrf_gpu seg faults

Open discussion for MAGMA

magma_sgetrf_gpu seg faults

Postby lcarring » Fri May 21, 2010 7:38 pm

Hi,

I am trying to install magma and it installs but the test for testing_sgetrf_gpu seg faults when the line:
magma_sgetrf_gpu(&N, &N, d_A, &lda, ipiv, h_work, info);

is executed.

It is running on the FERMI/Tesla C2050, is this supported. Anyone else have similar problems. Well, I thought I would ask before trying to dive into the magma source.

Thanks.
lcarring
lcarring
 
Posts: 1
Joined: Fri May 21, 2010 7:27 pm

Re: magma_sgetrf_gpu seg faults

Postby Allan Menezes » Sat May 22, 2010 3:33 am

Hi,
See my post for the results of tests I ran with a recompiled version of magma 0.2 source with CUDA3.0 and the GTX480 which is similar to the FERMI Tesla C2050.
Code: Select all
device 0: GeForce GTX 480, 1401.0 MHz clock, 1535.2 MB memory
device 1: GeForce GTX 470, 1215.0 MHz clock, 1279.7 MB memory

Usage:
  testing_sgetrf_gpu -N 1024



  N    CPU GFlop/s    GPU GFlop/s    ||PA-LU|| / (||A||*N)
==========================================================
1024     27.14          60.99         1.895988e-09
2048     46.63         157.01         1.774122e-09
3072     55.06         221.47         1.715500e-09
4032     60.07         253.08         1.804801e-09
5184     62.89         296.81         1.798921e-09
6016     64.07         315.18         1.675016e-09
7040     65.71         329.13         1.659101e-09
8064     66.71         336.04         1.770623e-09
9088     67.46         346.92         1.981117e-09
10112     68.23         353.69         2.168543e-09

If you recompile with the new Nvidia drivers it does not segfault for me as above.
Regards,
Allan
Allan Menezes
 
Posts: 14
Joined: Wed Aug 05, 2009 10:01 pm


Return to User discussion

Who is online

Users browsing this forum: Google [Bot], mgates3, Yahoo [Bot] and 1 guest