clMAGMA build problems with ACML

Open discussion for MAGMA

clMAGMA build problems with ACML

Postby yurtesen » Thu Nov 22, 2012 10:09 pm

1- the make.inc.acml contains mistakes. The LIBDIR lines are missing backslashes!

2- Instead of -I/opt/AMDAPP/include the include directory should be $(AMDAPPSDKROOT)/include , the SDK is not always installed to same place, but it sets the variable (perhaps variable should be used if it exists and overwrite /opt/AMDAPP, just in case)

3- And tests do not compile with following: (it compiles with ATLAS instead of ACML)

g++ -O0 -DADD_ -g -Wall -DHAVE_clAmdBlas -DHAVE_CBLAS -fPIC -Xlinker -zmuldefs testing_zhetrd.o -o testing_zhetrd lin/liblapacktest.a \
-L../lib -lclmagma -lclmagmablas -L/export/modules/devel/ACML/4.4.0/gnu/gfortran64/gfortran64/lib -L/export/modules/devel/ACML/4.4.0/gnu/gfortran64/gfortran64_mp/lib -L/export/modules/devel/clAmdBlas/1.8.291/lib64 -lacml -lacml_mv -lclAmdBlas -lOpenCL
../lib/libclmagma.a(zlatrd.o): In function `magma_zlatrd':
/home/eyurtese/tmp/temp/clmagma-1.0.0/src/zlatrd.cpp:252: undefined reference to `cblas_zdotc_sub'
/home/eyurtese/tmp/temp/clmagma-1.0.0/src/zlatrd.cpp:326: undefined reference to `cblas_zdotc_sub'
collect2: error: ld returned 1 exit status
make[1]: *** [testing_zhetrd] Error 1
make[1]: Leaving directory `/home/eyurtese/tmp/temp/clmagma-1.0.0/testing'
make: *** [test] Error 2


Any ideas on where to report these so they would get fixed?
yurtesen
 
Posts: 3
Joined: Thu Nov 22, 2012 9:49 pm

Re: clMAGMA build problems with ACML

Postby mb_infn_it » Mon Nov 26, 2012 6:44 am

http://icl.cs.utk.edu/magma/forum/viewtopic.php?f=2&t=711

you could check this thread to solve your problem.
hope it will be helpful.
mb_infn_it
 
Posts: 7
Joined: Wed Oct 10, 2012 4:39 am

Re: clMAGMA build problems with ACML

Postby mgates3 » Mon Nov 26, 2012 11:15 am

We'll look into improving the build process. As mentioned by another poster (thanks!), the other topic explains that cblas is required with ACML. Thanks for reporting the problems.
-mark
mgates3
 
Posts: 428
Joined: Fri Jan 06, 2012 2:13 pm

Re: clMAGMA build problems with ACML

Postby yurtesen » Wed Nov 28, 2012 6:31 pm

Yes, with gsl or using ATLAS, it is possible to compile it. Thanks for the information.
I now have more problems, it still does not seem to function....
viewtopic.php?f=2&t=808
yurtesen
 
Posts: 3
Joined: Thu Nov 22, 2012 9:49 pm


Return to User discussion

Who is online

Users browsing this forum: Google [Bot] and 5 guests