magma 1.3.0 fails to build on cuda 5.5 + gcc 4.7.2

Open discussion for MAGMA

magma 1.3.0 fails to build on cuda 5.5 + gcc 4.7.2

Postby lejeczek » Wed Feb 26, 2014 6:05 am

hi
just would like to ask experts if magma 1.3.0 should build on cuda 5.5 ?
my compilation fails:

gcc -O3 -DADD_ -fPIC -DHAVE_CUBLAS -DGPUSHMEM=200 -I/usr/local/cuda-5.5/include -I../include -I../control -c testing_zgemm.cpp -o testing_zgemm.o
../make.inc:40: *** unterminated variable reference. Stop.
make[1]: Leaving directory `/home/pe243/rpmbuild/tar.src/MAGMAlibs/magma-1.3.0.acml/testing'
make: *** [test] Error 2

is it because of cuda 5.5?
regards
lejeczek
 
Posts: 22
Joined: Tue Apr 09, 2013 2:57 am

Re: magma 1.3.0 fails to build on cuda 5.5 + gcc 4.7.2

Postby mgates3 » Wed Feb 26, 2014 6:17 pm

This looks like an error in your make.inc file. Check that file, especially at or around line 40, as the error message indicates. If you can't find the error, post your make.inc file here.

Off hand, I don't know any reason it would not compile with cuda 5.5. On the other hand, magma 1.3 is out-of-date. We suggest upgrading to the latest magma 1.4.1.

-mark
mgates3
 
Posts: 384
Joined: Fri Jan 06, 2012 2:13 pm


Return to User discussion

Who is online

Users browsing this forum: No registered users and 2 guests