build problems

Open discussion for MAGMA

build problems

Postby miahw » Fri Nov 18, 2011 10:20 am

Hello, I am trying to build Magma using icc and ifort, but keep getting this error:

nvcc --compiler-options -fno-strict-aliasing -DUNIX -O3 -DADD_ -arch sm_20 -DGPUSHMEM=200 -I/gpfs/grace/cuda-4.0.17/include -I../include -I../\
quark/include -I../control -c zauxiliary.cu -o zauxiliary.cu_o
../control/common_magma.h(107): error: identifier "cublasStatus_t" is undefined
../control/common_magma.h(108): error: identifier "cublasStatus_t" is undefined

cublasStatus_t is defined in cublas_api.h but common_magma.h does not include it. Is this correct? This sounds a bit trivial but I might be missing something :-)

Thanks in advance for your help,
Wadud.
miahw
 
Posts: 1
Joined: Fri Nov 18, 2011 10:16 am

Re: build problems

Postby Stan Tomov » Tue Nov 22, 2011 1:23 pm

Hello,
We include cublas.h where cublasStatus_t is defined as
Code: Select all
#define cublasStatus cublasStatus_t

We didn't see this problem on our systems. We will investigate it more and do the proper includes. Thanks for reporting it.
Stan
Stan Tomov
 
Posts: 249
Joined: Fri Aug 21, 2009 10:39 pm

Re: build problems

Postby fletchjp » Thu Nov 24, 2011 5:37 pm

Stan

I think this is a question of the version of CUDA and CUDABLAS. I am using CUDA 3.2 and that shows the problem, cured by adding the definition of cubasStatus_t. I have not yet checked in version 4.0

I had already reported the problem in an earlier post.

I have not seen anything in your installation files about what version of CUDA you are recommending.

John
fletchjp
 
Posts: 170
Joined: Mon Dec 27, 2010 7:29 pm

Re: build problems

Postby Stan Tomov » Thu Nov 24, 2011 7:12 pm

John,
Yes, it looks like this is a problem with the CUDA version. We always use the newest available (so this is 4.0 right now). I guess we would have to keep all versions on a system for testing and cover cases like this.
Stan
Stan Tomov
 
Posts: 249
Joined: Fri Aug 21, 2009 10:39 pm

Re: build problems

Postby fletchjp » Fri Nov 25, 2011 6:36 am

Stan

Thank you. I can look to moving to CUDA 4.0 provided I can sort out installation for the version of Ubuntu I currently use (10.4).

It should be possible to detect the CUDA version and put in a define for cublasStatus_t where needed.

Cheers

John
fletchjp
 
Posts: 170
Joined: Mon Dec 27, 2010 7:29 pm

Re: build problems

Postby Stan Tomov » Fri Nov 25, 2011 1:13 pm

John,
Thanks. I put it on our to do list for the next release.
Stan
Stan Tomov
 
Posts: 249
Joined: Fri Aug 21, 2009 10:39 pm

Re: build problems

Postby fletchjp » Tue Dec 20, 2011 7:26 pm

Stan

I had this problem earlier when I was using CUDA 3.2. I have now moved to CUDA 4.0 and am surprised to find that I am getting the opposite problem that a lot of files use cudablasStatus which they say is underfined. I change this to use cudablasStatus_t and the error goes away. The files involved are:

{c,d,s,z}gehrd.cpp {c,d,s,z}gehrd2.cpp {c,z}hetrd.cpp {d,s}sytrd.cpp (all in src directory) and transpose.h in control directory.

I hope this helps.

John
fletchjp
 
Posts: 170
Joined: Mon Dec 27, 2010 7:29 pm

Re: build problems

Postby luiceur » Tue Sep 04, 2012 9:45 am

Hi all,

If I am not mistaken, it should be:

Code: Select all
#define  cublasStatus_t  cublasStatus


And I had to add it with version 4.0, but not with 4.2
luiceur
 
Posts: 26
Joined: Tue Jul 10, 2012 4:38 am

Re: build problems

Postby mgates3 » Tue Sep 04, 2012 11:17 am

According to the CUBLAS_Library.pdf documentation, the correct type is cublasStatus_t.
The cublas.h header includes cublas_api.h, which typedefs cublasStatus_t. The cublas.h also has
#define cublasStatus cublasStatus_t
to replace old occurrences of cublasStatus with the correct cublasStatus_t type. This appears to be true for CUDA 4.0, 4.1, 4.2, and 5.0.

-mark
mgates3
 
Posts: 387
Joined: Fri Jan 06, 2012 2:13 pm


Return to User discussion

Who is online

Users browsing this forum: Bing [Bot] and 2 guests