the error when I compile magma1.4.0 in vs2010

Open discussion for MAGMA

the error when I compile magma1.4.0 in vs2010

Postby Eva Joo » Mon Sep 09, 2013 4:57 am

when i compile magma 1.4.0 in vs2010.it always appear errors in magma-1.4.0\include\magma_types.h
Code: Select all
 fatal error C1189: #error :  "One of HAVE_CUBLAS, HAVE_clAmdBlas, or HAVE_MIC must be defined. This typically happens in Makefile.internal
how can i solve it .thanks.
Eva Joo
 
Posts: 3
Joined: Mon Sep 09, 2013 4:49 am

Re: the error when I compile magma1.4.0 in vs2010

Postby Stan Tomov » Mon Sep 09, 2013 9:20 am

HAVE_CUBLAS has to be defined, e.g., by adding -DHAVE_CUBLAS to the compiler options. In Linux, the compiler options are set in Makefile.internal based on user input from make.inc.
Stan Tomov
 
Posts: 251
Joined: Fri Aug 21, 2009 10:39 pm

Re: the error when I compile magma1.4.0 in vs2010

Postby Eva Joo » Thu Sep 12, 2013 4:54 am

Stan Tomov wrote:HAVE_CUBLAS has to be defined, e.g., by adding -DHAVE_CUBLAS to the compiler options. In Linux, the compiler options are set in Makefile.internal based on user input from make.inc.

thanks a lot for your reply.i am not very clear. i need built a part of the files one one by one in vs2010.i can't use makefile . can i set the compiler option in vs2010 or can i
revise it in the magma_tpye.h ? i come into contact with this just now. thanks very much.
-Eva
Eva Joo
 
Posts: 3
Joined: Mon Sep 09, 2013 4:49 am

Re: the error when I compile magma1.4.0 in vs2010

Postby Stan Tomov » Fri Sep 13, 2013 1:14 am

You should be able to specify compiler options in vs2010, but I haven't used it recently and I am not sure where exactly. The other way is to revise the magma_types.h, e.g., by adding after the include statements a
Code: Select all
#define HAVE_CUBLAS
Stan Tomov
 
Posts: 251
Joined: Fri Aug 21, 2009 10:39 pm


Return to User discussion

Who is online

Users browsing this forum: No registered users and 1 guest