Segmentation violation when running MAGMA rc4 tests

Open discussion for MAGMA

Segmentation violation when running MAGMA rc4 tests

Postby evanlezar » Sat Mar 12, 2011 9:05 am

I have been trying to get MAGMA 1.0.0-rc4 running and have run into a problem. Every one of the testing programs causes a segmentation fault. Furthermore, this segmentation fault is thrown before any of the code in the main routine is executed. The gdb output for the testing_sgemm program is shown below.

Has anyone else had such problems?

Thanks

Code: Select all
elezar@xpsy:~/src/cuda/magma_1.0.0-rc4/testing$ gdb testing_sgemm
GNU gdb (GDB) 7.2-ubuntu
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /home/elezar/src/cuda/magma_1.0.0-rc4/testing/testing_sgemm...done.
(gdb) run
Starting program: /home/elezar/src/cuda/magma_1.0.0-rc4/testing/testing_sgemm

Program received signal SIGSEGV, Segmentation fault.
0x0000000000000001 in ?? ()
evanlezar
 
Posts: 33
Joined: Tue Aug 25, 2009 7:20 pm
Location: Stellenbosch, South Africa

Re: Segmentation violation when running MAGMA rc4 tests

Postby evanlezar » Sat Mar 12, 2011 9:52 am

I seem to have solved the problem.

The issue is that my make.inc had CC=gcc -shared and as such the executables were being compiled as shared libraries. Setting CC=gcc in the testing Makefile and including some of the other object files for the compilation solved the problem.
evanlezar
 
Posts: 33
Joined: Tue Aug 25, 2009 7:20 pm
Location: Stellenbosch, South Africa


Return to User discussion

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Yahoo [Bot] and 1 guest