MAGMA RC5 testing error "cudaError_enum"

Open discussion for MAGMA

MAGMA RC5 testing error "cudaError_enum"

Postby woody » Thu Jul 21, 2011 10:58 am

Hello

I have the following file make.inc

Code: Select all
#//////////////////////////////////////////////////////////////////////////////
#   -- MAGMA (version 1.0) --
#      Univ. of Tennessee, Knoxville
#      Univ. of California, Berkeley
#      Univ. of Colorado, Denver
#      November 2010
#//////////////////////////////////////////////////////////////////////////////

#
# GPU_TARGET specifies for which GPU you want to compile MAGMA
#      0: Tesla family
#      1: Fermi Family
#
GPU_TARGET = 0

CC        = gcc
NVCC      = nvcc
FORT      = gfortran

ARCH      = ar
ARCHFLAGS = cr
RANLIB    = ranlib

OPTS      = -O3 -DADD_
FOPTS     = -O3 -DADD_ -x f95-cpp-input
NVOPTS    = --compiler-options -fno-strict-aliasing -DUNIX -O3 -DADD_
LDOPTS    = -fPIC -Xlinker -zmuldefs

LIB       = /usr/local/src/lapackbld/lapack-3.1.1/lapack_LINUX.a \
            -lf77blas -latlas -lcblas -lf2c -lcublas -lm \
            /usr/local/hplbenchmarks/lib64/libgfortran.a

CUDADIR   = /usr/local/cuda

LIBDIR    = -L/usr/local/src/ATLAS/nisl64/lib \
            -L/usr/local/src/CLAPACK-3.1.1.1/F2CLIBS/ \
            -L/usr/local/hplbenchmarks/lib64/libgfortran.a \
            -L$(CUDADIR)/lib64
INC       = -I$(CUDADIR)/include

LIBMAGMA     = ../lib/libmagma.a
LIBMAGMABLAS = ../lib/libmagmablas.a


however, I got the following error message:

[root@localhost testing]# ./testing_dgeqrf_gpu
terminate called after throwing an instance of 'cudaError_enum'
Aborted


Thank you for any help
woody
 
Posts: 8
Joined: Thu Jul 21, 2011 10:02 am

Return to User discussion

Who is online

Users browsing this forum: Bing [Bot] and 2 guests

cron