Page 2 of 2

Re: Error finding event LLC_REFERENCES in make test

PostPosted: Mon Mar 30, 2015 3:30 pm
by yarkhan
Hello,

Thanks for noting the problem with _vmware_init_thread. I believe that you are correct and this is a bug in the thread initialization call.
There is no such a function called _vmware_init in this file. There is a function called _vmware_init_thread and I guess this is exactly the function which should be assigned to the .init_thread. So I changed this line into:

I will put this correction into PAPI.

It is normal that you have to set the include path, library path, and LD_LIBRARY_PATH for headers and libraries. Some of that would have worked out if the GuestSDK was where it used to be and the configure.in script had been run with that information. However, you seem to have completed all that now!

About the error message
UpdateInfo failed: VMware Guest API is not enabled on the host

I searched google for that message "VMware Guest API is not enabled on the host" and found some relevant information in the second result.
https://www.vmware.com/pdf/GuestSDK10.pdf
Search pdf for "VMware Guest API is not enabled" and found this:
"The VMware Guest API is not enabled on this host, so these
functions can not be used. For more information about how
the to enable the library, see Disabling the VMware Guest API
on page 6."
Following to page 6 of the pdf, there are some instructions on re-enabling the GuestAPI.

With regard to "not supported" messages for stalled-cycles-frontend/backend, I am afraid I still do not know what might be causing this.
If you have not already tried this, try using your machine without the VMWare layer (bare-metal).
Try VMware on an older machine if you have one available, to see if this is a cpu support issue.

Good luck and let us know.
Asim